Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Pro Wireless 3945ABG Connect: Button Grayed OUt


  • Please log in to reply
2 replies to this topic

#1 milkandgin

milkandgin

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:06:16 PM

Posted 28 August 2009 - 11:00 PM

Hello,

My chipset will--or would, as the case may be--only connect to a wireless network using the wireless utility provided by intel. Until recently, it worked fine. I had my wireless information saved into the utility, so it was a matter of opening the utility and connecting. About a month ago, I noticed the 'connect:' button would be grayed out if I tried to connect to any other wireless networks. It didn't bother me, because it would connect to mine because, as I said, the I had my wireless information saved in a profile. Last night my internet wasn't working, so I tried to connect to another network and deleted my profile. Now, it will find 12 wireless networks in range, but if I click on any of them, including mine, the 'connect:' button will be grayed out. The switch for the wifi hardware is on, and I've tried toggling it on and off to no avail.

I have no clue what's going on with it. I've tried updating the drivers but nothing changes it. I am only able to connect to the internet through my linux (ubuntu) partition. I used the
'lshw' command in the ubuntu terminal to print the information on my hardware for your help. This is what it shows:

*-network
description: Wireless interface
product: PRO/Wireless 3945ABG [Golan] Network Connection
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wmaster0
version: 02
serial: 00:19:d2:b6:e6:f4
width: 32 bits
clock: 33MHz
capabilities: bus_master cap_list logical ethernet physical wireless
configuration: broadcast=yes driver=iwl3945 ip=192.168.2.100 latency=0 module=iwl3945 multicast=yes wireless=IEEE 802.11abg


Thanks in advance!

P.S. If you give me any instruction, I'll save it in a text doc and write it to my windows partition, perform the actions, test it, and come back to ubuntu to report should it not work.

P.S.

I also wish I could fix it so I can just use windows xp to manage my wireless connections. I could never get that to work, however.

BC AdBot (Login to Remove)

 


#2 milkandgin

milkandgin
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:06:16 PM

Posted 30 August 2009 - 08:04 PM

sorry for the bump, but anyone have an idea?

#3 hamluis

hamluis

    Moderator


  • Moderator
  • 55,245 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:06:16 PM

Posted 31 August 2009 - 08:01 AM

I don't do wireless...but I would just set the connection up anew, using the Network Connection Wizard in XP.

As for updating drivers...I find that it's best to remove all drivers for that device, then reinstall or update...rather than trying to install good drivers on top of driver files which may be damaged.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users