Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Input Devices Not Functional


  • Please log in to reply
No replies to this topic

#1 dwdonahue

dwdonahue

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:46 PM

Posted 28 August 2009 - 01:31 PM

This problem has a bit of a back-story, and I will also sum up the steps I have taken to attempt solving it.

1. I installed Ubuntu 9.04 within Windows Vista (on Dell Inspiron 1520).
2. I moved from IL to CA.
3. When I finally received all my computer hardware (some shipped), mouse and number pad were not working. Windows did not even recognize that anything had changed when I plugged them in.
Note: *Two External hard drives ARE working.*
4. Figured the mouse was shot (very old), bought a new one. This also produced no effect in Windows.
5. Thinking my Ubuntu install had screwed with some drivers, I uninstalled Ubuntu and restarted. This produced no change.
6. I then used System Restore to go back before the Ubuntu install; upon restart, I could no longer boot Windows without a blue screen.
7. I ran diagnostics, and came up with an error:
Hard Drive
DST Short Test
Error Code 0148
MSG Error Code 2000-0148
MSG Unit 0:1DE Error:
Status 3E No additional sense information

8. This error led me to believe I had a hard drive failure. I then reformatted, but used Ubuntu because I did not have my Vista CD with me.
9. After clean Ubuntu install, input devices still did not work, but everything else was working fine, no more blue screens. (I did multiple updates and driver checks to make sure my input devices were supported in Ubuntu.)
10. For kicks, I downloaded Windows 7 from my developer's account, then did a clean reformat. Again, everything works fine, but input devices (mice, keypad) have no effect.
11. I ran diagnostics one more time, and received no error.


My attempts to fix this have included:
-Uninstalling/Reinstalling all USB modules in Device Manager.
-Removing battery and unplugging computer, left to sit overnight.
-Using different USB ports.
-Using a USB Hub.
-Updating all drivers, bios, and chipset from Dell.

Please bear in mind that, through all these steps, USB storage devices (hard drives, iPod) have all worked just fine.

Any ideas?
Thanks so much for your help.

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users