Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windowed emacs in X11


  • Please log in to reply
1 reply to this topic

#1 badmonkey

badmonkey

  • Members
  • 50 posts
  • OFFLINE
  •  
  • Local time:05:59 PM

Posted 20 July 2005 - 10:53 AM

Dear BleepingComputer,

I noticed that the built in emacs does not open up a new window in X11 - instead it runs in the terminal.
However if I start an emacs session on a remote computer X11 will give me a new window.

Any thoughts as to why this is?

Thanks
Badmonkey
10.4.2

BC AdBot (Login to Remove)

 


#2 badmonkey

badmonkey
  • Topic Starter

  • Members
  • 50 posts
  • OFFLINE
  •  
  • Local time:05:59 PM

Posted 21 July 2005 - 04:26 PM

The issue has been resolved.

Apparently Apple decided to compile emacs with the X11 options turned off (as the built in Terminal doesn't do windowing and X11 isn't installed by default).

I installed Fink which then allowed me to install emacs again, this time with the X11 options enabled.

Sounds easier than it was as I first had to update my XCode from 2.0 to 2.1 as gcc4 of XCode 2.0 had sever problems (a known issue). So 750MB later I got Fink to work the way it was supposed to and also compile from the emacs source. Works like a charm now.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users