Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Bad SATA controller?


  • Please log in to reply
4 replies to this topic

#1 MrCallahan

MrCallahan

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:08:06 PM

Posted 25 August 2009 - 10:54 AM

I'll give the specs first:

MB: MSI K9A2 Platinum
CPU: Phenom II 940
HD1: WD Caviar 1TB (OS, all non-game programs)
HD2: Seagate Barracuda 1TB (Old OS drive, cloned it to Caviar then used Caviar as main, haven't modified it since)
HD3/4: 2x WD Raptor 300GB in RAID 0 on Promise controller(Steam/Games)
Optical: Toshiba DVD burner
RAM: 8GB OCZ 1066 DDR2
OS: Vista

Computer was running fine for months. Didn't make any changes to anything, just started it up yesterday as normal. Noticed that VLC wouldn't load when I clicked on videos. I could start VLC and load a video, but couldn't open it by double clicking or right clicking files. Then Steam wouldn't run, first giving a blank GUI box with garbled text in the title bar, then stating it couldn't find the target for the shortcut. Steam is on the Raptors, not the main drive. Process Explorer showed 2 instances of Steam, and I couldn't shut down either one. Reboot, it runs checkdisk automatically on the Raptors, says it found some free space allocated wrong, fixes it. Then I get into Vista and it starts going nuts. I can run some programs and some games, but eventually it will slow down and the programs will stop responding. Sometimes this happens right away, other times after 10 or 20 minutes. I can shut down from Windows sometimes, other times I can't.

I try booting with the Seagate. Same issues. Unplug everything but the main drive, same thing. Tried all combos of all SATA devices, same problems. I ran PC-Check, it says there is a parallel ATA controller, but serial ATA is marked Absent. Also says there is no CD/DVD drive, even though PC-Check is running from the DVD drive. Spinrite locks up.

I updated the BIOS to 1.8 (was 1.7), and the first reboot with the Raptors I got a hardware error when it ran the Fasttrak RAID config during bootup. Unplugged them and now I am able to run with just the OS drive and DVD attached, but PC-Check still says there is no serial ATA and no CD/DVD.

I can try installing the Raptors on the regular SATA ports instead of the Promise controller, but I would rather avoid a reinstall of all my games. That also doesn't fix the odd errors with PC-Check. Is there a way to reinstall the whole SATA controller, or is this likely fried hardware? I feel as though I'm missing a step somewhere that will at least tell me what's wrong.

Any help would be greatly appreciated!

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,385 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:06 PM

Posted 25 August 2009 - 12:31 PM

Error messages, verbatim, please?

What made you title your thread as you did?

Louis

#3 MrCallahan

MrCallahan
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:08:06 PM

Posted 26 August 2009 - 11:56 PM

There are no error messages except the lone message in checkdisk about misallocated free space. I don't recall the exact text, and it hasn't happened again. Vista just hangs. It doesn't freeze completely, as I can usually still move the mouse cursor, and sometimes open the start menu, and even run another program. It will show the busy cursor, but nothing will happen.

The reason I wondered about the SATA controller is that all 4 hard drives (well 2 individual drives and the RAID array) had problems of one sort or another, and they were all working fine just the day before. I mentioned that Spinrite would lock up, usually in the main menu before it even let me select drives, and PC-Check said there was no SATA controller and no optical drive, which is a SATA drive as well, even though the program was running from a CD. However, I realized later that I'm not sure if PC-Check ever did detect my SATA controller or DVD drive when everything was working properly.

#4 arcman

arcman

  • Members
  • 706 posts
  • OFFLINE
  •  
  • Location:Michigan
  • Local time:12:06 AM

Posted 27 August 2009 - 10:50 AM

I would run a bootable hard drive diagnostic, first.
If you have the CDs that came with the drives use those, otherwise try the UBCD
Posted Image

#5 MrCallahan

MrCallahan
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:08:06 PM

Posted 27 August 2009 - 11:06 PM

Got it working, seems the RAID array was corrupted. I'm not sure why Vista froze the first time I booted without those drives attached, but I wiped the array and set it up as JBOD on the Promise controller. Have to reinstall all the games, but better than replacing hardware any day.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users