Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Trying to Setup an SSH Proxy Tunnel Through Port 443/80, Only Works at Port 22


  • Please log in to reply
No replies to this topic

#1 Cloudwalker

Cloudwalker

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:44 PM

Posted 22 August 2009 - 05:44 AM

What Iīm trying to accomplish is to setup a proxy at home so I can use it at work to get around the proxy they have that blocks almost all web-content, they also have a firewall that I believe doesnīt allow traffic through port 22

I have searched alot, since I am an intermediate user, & English is my second language, I have had a little problem finding an easy to read guide.

I have tried openSSH, Iīve installed it then
created a group:

mkgroup -l >> etc\group
mkpasswd -l -u %username% >> etc\passwd
net start opensshd

That all seems fine.

Then I Downloaded Putty,

- I wrote my ip-adress on host
- picked SSH encryption

- On SSH tunnels i forwarded sourceport 80 - localhost:8080 ,443 - localhost:8081 & 1080 - localhost:1080
(according to some setup guide I found)

- First i tried port 22 (it worked fine) I can connect and through the putty prompt I get to write my login & pass then it works..

Then i Tried to change to port 443 which didnīt work, then tried 80 which also refused.

What happens when setup at those ports is that the putty promt that are suppose to ask for login % pass just goes empty.. I wonder Why?


************************************************** ********************
My connection is LAN through fiber, i havenīt got any router or NAT device in front. & I havenīt got any software firewalls or even the windows firewall on.

Using Windows XP-SP3

Can someone point me to a guide that is easy to understand or explain to me what i might be doing wrong when i try to connect through port 443 & canīt get it to work?

Would really aprociate if someone took the time.. Thanx!!

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users