Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Messed up hard disk partitions - really need help


  • Please log in to reply
No replies to this topic

#1 HydraHeaded

HydraHeaded

  • Members
  • 42 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:12:37 PM

Posted 17 August 2009 - 08:28 PM

I've two hard disks, both SATA. One is an 80 GB one, from which I run XP and Vista, the other is a 1 TB one which I use for storage. XP is on C:\ (10 GBs), Vista on D:\ (30 GBs). I use XP most of the time and I mess it up pretty fast, so I have made an image of the disk. Generally I reinstall the image onto C:\, only thing is the image is an old one, before I installed Vista, so the Vista bootloader vanishes. For this, I use Easy BCD to install the Vista bootloader.

Now what I was trying to do is this: I thought I would make a 50 MB partition in C:\ drive, and keep all the boot info there, so that I could easily format C:\ and use it without messing with the boot. I used Vista's Shrink to make a 50 MB partition of C:\. At this time, when I went to Computer Management > Disk Management, it was showing the first hard drive (80 GB) as: C:\ (primary), B:\ drive (the 50 MB partition, also shown as primary, in dark blue), and the rest of the four partitions as Extended in green. It showed the 1 TB hard disk as an extended one, in green. Then I booted into XP, and the drive letter for the 50 MB partition was shown as Q:\ or something, so I tried to change it to B:\, but there wasn't any option for that. At this time, I right-clicked the 50 MB drive in Disk Management and selected make it active. Then I started Easy BCD and I'm not exactly sure what I did, but I clicked something about installing the bootloader on the 50 MB partition. Then I rebooted, and the whole thing was gone, there was a message from the Vista bootloader that the computer couldn't boot and I should pop in the Vista CD. When I did that, and tried to repair the installation by repairing the startup, it kept doing something and rebooting for five six times without any effect.

At this time, I shut down the computer, and got a previous hard disk of my old computer, a 40 GB one, which is not SATA (it has that many pins wire) and booted from that. Now in Disk Management it showed three hard disks: one was the present 40 GB one from which I had booted, the other was the 1 TB one, shown without any errors, and the third was the 80 GB one, and I'm not sure what I did here, but the drive vanished from Disk Management after this, so that only the 40 GB and the 1 TB ones are now displayed.

I then removed the 40 GB one, fitted the 80 GB and the 1 TB one and booted from the Vista CD, meaning to install Vista again (I tried XP first but at one point, even before it asked where to install, it would stop using the CD and kept scanning the hard disk, the hard disk light was continously on, and nothing was responding.) In the Vista setup, it asked for a fresh installation, so I thought I'd format D:\ (on 80 GB) which originally had Vista, and reinstall the whole thing. But when it came to selecting the partitions, the setup displayed only one single partition, a 75 GB unallocated space (the 80 GB partition). When I clicked next, setup said it was not possible to install Vista onto this drive, that it was not possible to boot from it, and that I should make it bootable by going to the computer's BIOS. So setup couldn't continue, and I went into the BIOS, but couldn't find anything there.

Then I booted from the 40 GB one, with the 1 TB one attached, and again in Disk Management I clicked some option which ended up damaging that one as well. Later when I tried to run setup again, it was missing out some drives on the 1 TB one and showing two 8 MB drives. So at present, with all three drives installed, and booting from the 40 GB one, it shows only two drives: one is the 40 GB one, and the other is the 1 TB one, with some partitions damaged, shown as free space (none of the partitions were really empty.) I'm including a screenshot of how it looks now. The 1 TB one has a lot of partitions, that's how I had partitioned it. The ones in green shown as free space actually contain data, and pretty much packed to the full. There is another partition at the end which is not shown, which is an ext partition I made when tinkering with Linux.

Now if I boot from a Puppy Linux CD, it shows all hard disks, but not all partitions. For the 80 GB disk, it doesn't show one 10 GB partition at the end. It does display it as sda7 but when I click on it, the Mount Manager opens and there is no option anywhere to mount it. The same problem is for the 1 TB one, shown as sdb: most of the partitions can be opened, but the ones that Windows Disk Management shows as free space are displayed as sdb2, sdb4, etc, but they cannot be opened.

At a later stage, I used a software called Partition Table Doctor, and I'm including a screenshot of how it shows the 80 GB one (it shows a Linux partition there, when I never made one on it for sure).

I just don't know how I messed it up so bad. So, how do I restore the whole thing to like what it earlier was?

Attached Files



BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users