Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Task Manager is disabled.

  • Please log in to reply
3 replies to this topic

#1 wfrazier


  • Members
  • 28 posts
  • Local time:11:43 AM

Posted 16 July 2005 - 05:58 PM


Recently was a victim of SpySheriff and a number of virus/trojan/downloader attacks. I've eliminated the offending files, but still need to repair a couple of changes made to my system.

First of all, when I press cntl-alt-delete to start Task Manager if get the message

"Task manager has been disabled by your administrator"

Next if I open Control Panel/Administrative Tools the following items will not open when double clicked. 1. Component Services 2. Computer Management 3. Event Viewer. When I check the properties of these items it states "This is not a valid shortcut" Also, the Find Target buttons are grayed out and you can't type into the Target or Start IN fields.

I can start all these items if I go directly to System32 and double click the file entry.

My system is Windows XP Home Edition, Version 2002, SP2.

Can you tell me where I need to go to re-enable Task Manager?

I do have a program called WinTasks Pro, which is an enhanced Task Manager. I can start it and end tasks using it, but would also like to have Windows TaskManager back.

Thanks in advance..

Bill (WFrazier)

BC AdBot (Login to Remove)


#2 TEB


  • Banned
  • 449 posts
  • Local time:02:43 PM

Posted 16 July 2005 - 08:50 PM

Instructions for re-enabling the task manager can be found here:

But the google adds on the page block out half of the article so i quickly reloaded the page and copied it to a different frame and copied and pasted it.

Error Message: "Task Manager has been disabled by your administrator"

This error is caused by restrictions placed in Registry. DisableTaskMgr value is set to 1. To enable Task Manager, try any of these methods:

Method 1

Click Start, Run and type this command exactly as given below: (better - Copy and paste)

Method 2

Download and run this REG fix and double-click it (reg fix found here)

Method 3

    * Open Registry Editor (Regedit.exe) and navigate to:

    HKCU \ Software \ Microsoft \ Windows \ CurrentVersion \ Policies\ System

    * In the right-pane, double-click DisableTaskMgr and set it's data to 0

Method 4:  Using Group Policy Editor [ Windows XP Professional ]

    * Click Start, Run, type gpedit.msc and click OK.
    * Navigate to this path

    User Configuration
    => Administrative Templates
    ==> System
    ===> Ctrl+Alt+Delete Options
    ====> Remove Task Manager

    * Double-click the Remove Task Manager option.
    * Set the policy to Not Configured.

Edited by Techsomething, 16 July 2005 - 08:53 PM.

#3 tg1911


    Lord Spam Magnet

  • Members
  • 19,274 posts
  • Gender:Male
  • Location:SW Louisiana
  • Local time:01:43 PM

Posted 16 July 2005 - 08:58 PM

NOTE: If you're not familiar with working in the registry, DO NOT ATTEMPT to make any changes.
Improper changes to the registry could render your computer inoperable.
If you decide to attempt it, remember to backup the registry before making any changes.
Instructions, on how to do that, can be found here:
Backing up the Registry
MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook

#4 wfrazier

  • Topic Starter

  • Members
  • 28 posts
  • Local time:11:43 AM

Posted 16 July 2005 - 10:03 PM

Thanks TEB,

That did it. I used Method #3 (the simplest of the bunch).

I'm going to add that url to my favorites. I'm going to need more help before things are back to normal.

Take care....

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users