Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


iTunes won't install, and can't remove old version

  • Please log in to reply
2 replies to this topic

#1 john300000000


  • Members
  • 2 posts
  • Local time:10:57 AM

Posted 09 August 2009 - 06:46 AM

Help! I'm trying to update my iTunes from 7.5 to the latest version, but i've gone from bad to worse.
I"ve downloaded the itunessetup.exe, but after going through a few paces I get this error message: "The feature you are trying to use is on a network resource that is unavailable. Click OK to try again, or enter an alternate path to a folder containing the installation package "iTunes.msi" in the box below. User source: (then there's a drop down that gives me two choices) C:\Documents and Settings\John\Local Settings\Application Data\Apple\Apple Software Update\ OR C:\Documents and Settings\All Users\Application Data\Apple Computer\Installer Cache\iTunes\

Whichever I pick, the result is the same, another error message, which says: "The path '(it repeats the path i listed above)\iTunes.msi' cannot be found. Verify that you have access to this location and try again, or try to find the installation package 'iTunes.msi' in a folder fron which you can install the product iTunes.

When I close those boxes, i get another error message that says "The older version of iTunes cannot be removed. Contact your technical support group."

So, I'm guessing that the problem has to do with removing the old version.

I have tried going to my "Change or Remove Programs" function. But when I try to remove iTunes, I get the original error message again ("The feature you are trying to use is on a network resource that is unavailable, etc ...).

I've also tried dragging the old iTunes program files into the trash -- which has left me with no iTunes, but hasn't help me install the new version. ugh.

I am the administrator on my computer, so theoretically i should have access to everything. The computer is a Dell XPS 400 that runs Windows XP Media Center Edition. It's a home computer, which other family members also use (but i've made sure to log all of them off while attempting this upgrade).

Any ideas how I can remove the old version and install the new one?
Or who I can contact (at Apple or Dell or Microsoft) to help me figure it out?

Thanks !!!!!

-- John

BC AdBot (Login to Remove)


#2 john300000000

  • Topic Starter

  • Members
  • 2 posts
  • Local time:10:57 AM

Posted 09 August 2009 - 06:05 PM

Good news. I figured it out. I called iTunes tech support. The Apple guy wouldn't help me because my iPod is 800 days past the time when i'm eligible for phone support. But I coaxed enough info out of him to find my way to the right info on the Apple Web site.

If you have a similar problem, go here:

Scroll down a bit and click on "Clean up iTunes installer files on the computer."
Follow the instructions and you'll be directed to a place that you can download "msicuu2.exe", which will magically remove your stubborn old iTunes and QuickTime.

Once I did that, I was able to install the latest version of iTunes with no problems.

#3 camaj


  • Members
  • 1 posts
  • Local time:12:57 PM

Posted 15 October 2011 - 03:41 PM

I just want to say you are the BEST. Ive been soooooo frustrated for the past two hours trying to add all my music to my new iphone and have searched for what seemed like an eternity for the answer and here it is..in plain english clear as day I bleepin LOVE ya.

hahahahahaha by the way I didnt type "bleepin" the site automatically corrects it to that i guess. CUTE!


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users