Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Right-click-->"send to email recipient" opens wrong client compose window--is there a registry value?


  • Please log in to reply
4 replies to this topic

#1 supertramp

supertramp

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:02:16 AM

Posted 07 August 2009 - 01:34 PM

Thanks for your help - I've tried the usual settings and searched everywhere but can't find an answer to this question. Maybe I need to go into the registry?

Windows Home Premium, SP1.

I use Thunderbird as my default email client. Somehow, the default setting in Vista got changed - now when I right-click on a file and choose Send to-->Email recipient, I get an Outlook 2003 compose window, instead of a Thunderbird compose window. This drives me crazy. The computer behaves correctly (goes to Thunderbird) when I click on a "mailto:" hyperlink, however.

I've tried:
1. changing the settings in the Control Panel-->Default Programs window. There are 3 windows I've tried here with no luck.
a. "Set your default programs": I've checked to ensure that Thunderbird has all its defaults and Windows Mail and Outlook 2003 have none. I've also gone into each of these programs to make sure they're not stealing their defaults back.
b. I've gone into "Set Program Access and Defaults". In the Microsoft Windows section, Windows Mail is indicated as the default client, however there is no option to change it. In the Non-Microsoft section, the options set are "Use my current email program" and "Remove Access: Windows Mail". In this window, I am able to change the broswer, media player and Java settings, but it's not letting me change the email settings.
c. In the Custom window, under the setting Choose my default e-mail program, Thunderbird is not listed (nor is Outlook, for that matter). The option "Use my current email program" is checked, and Windows Mail (the only other option listed) is not checked. I have unchecked the box "Enable access to this program" as well.


Any suggestions? The start menu is defaulting to Thunderbird just fine - it just seems to be the "Right click-->send to" option that is not functioning properly, which makes me think maybe it's something in the registry. I use it all the time and it's driving me crazy!!!

Thanks for your help.

PS - one other item is puzzling. In Picasa, the option "Use Thunderbird to send email" is checked. However, when I go to email a photo, it opens an OUTLOOK window rather than a TB one. @#$$%%^&!

Edited by supertramp, 07 August 2009 - 01:37 PM.


BC AdBot (Login to Remove)

 


#2 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:01:16 AM

Posted 07 August 2009 - 01:58 PM

Did you try setting the default action under 'Control Panel', "Programs", "Default Programs" ... I can't remember exactly the sequence for Vista, but that should be right.

#3 supertramp

supertramp
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:02:16 AM

Posted 07 August 2009 - 02:15 PM

Thanks for the suggestion - I did do that - I think you're referring to the Default Programs window described in my first post.

I solved the problem...Here is the answer:

http://forums.mozillazine.org/viewtopic.ph...9&t=1314185

I had to first change the default program in the registry from Outlook to Mozilla Thunderbird, and then set the DLL path in the registry key described in the post above. Here is another link for anyone who's having the same trouble:

http://groups.google.com/group/mozilla.sup...161f08e44d75b0b

Onwards!

#4 supertramp

supertramp
  • Topic Starter

  • Members
  • 16 posts
  • OFFLINE
  •  
  • Local time:02:16 AM

Posted 07 August 2009 - 02:18 PM

Thanks for the suggestion - I did do that - I think you're referring to the Default Programs window described in my first post.

I solved the problem...Here is the answer:

http://forums.mozillazine.org/viewtopic.ph...9&t=1314185

I had to first change the default program in the registry from Outlook to Mozilla Thunderbird, and then set the DLL path in the registry key described in the post above. Here is another link for anyone who's having the same trouble:

http://groups.google.com/group/mozilla.sup...161f08e44d75b0b

Onwards!

#5 groovicus

groovicus

  • Security Colleague
  • 9,963 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Centerville, SD
  • Local time:01:16 AM

Posted 07 August 2009 - 02:31 PM

Oops. Sorry. I didn't see that you had tried that. :huh:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users