Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows error: DRIVER_IRQL_NOT_LESS_OR_EQUAL


  • Please log in to reply
1 reply to this topic

#1 Rawrz

Rawrz

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:09:27 AM

Posted 06 August 2009 - 03:19 PM

I did a registry fix for World of Warcraft (which works fine on my boyfriends computer) but did not work at all on my computer. I added TcpAckFrequency into HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\Interfaces\ as a new DWORD, and changed the value to 1. Then I added TCPNoDelay into HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\MSMQ\Parameters as a new DWORD with a value of 1. I double-checked and then re-double-checked that I did it correctly. When I rebooted my computer, first I couldn't connect to the internet (a wireless connection) and then things got worse as I restarted; it started freezing on the desktop or freezing before it even got that far. Then I got the DRIVER_IRQL_NOT_LESS_OR_EQUAL blue screen. I jumped into safemode and deleted the two new registry values but that did not fix the problem. I then searched for the problem through Microsoft Help and came up a with a hotfix which worked temporarily (after using it in safemode), which got me to my desktop screen booting regularly. All was fine and dandy until my computer attempted to connect to a wireless connection. Here is the link to the hotfix that I used: http://support.microsoft.com/kb/829120/en-us.

At this point, I'm at a loss. I've since system-restored two times to no avail. I've tried safe mode with networking but it froze when entering that so I'm assuming it has to do with the internet.

I want to avoid reformatting at all costs and I'm not sure what to do next.

Please help me, I would greatly appreciate it.

BC AdBot (Login to Remove)

 


#2 Romeo29

Romeo29

    Learning To Bleep


  • Members
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:09:27 AM

Posted 06 August 2009 - 06:55 PM

This error means that a driver attempted to access memory using a kernel process IRQL(interrupt request level) that was too high for your system. Drivers that have used incompatible addresses cause this error. A bad RAM module can also cause this.

In plain words, a driver is not right for your system. It is not meant for your Windows version, or, it is not compatible with Windows at all, or, the hardware needs some special driver, etc. From the error you get, it appears that the faulty driver is associated with the wireless network adapter.

What you should do is boot into safe mode and uninstall your wireless network card driver. Just open Device Manager and remove wireless network adapter. Check for any updated drivers for your adapter on the manufacturer's web site and install them instead.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users