Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

unable to turn off system restore


  • Please log in to reply
7 replies to this topic

#1 lazybones09

lazybones09

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:15 PM

Posted 04 August 2009 - 10:09 PM

i tried disabling the system restore but the messages "sytem restore encountered an error trying to enable/disable one or more drives. please restart your machine and try again"-- and/or "system restore is not able to protect your computer. please restart".. After countless times of rebooting the computer the same problem occured. why is that?

much help is appreciated

BC AdBot (Login to Remove)

 


#2 Romeo29

Romeo29

    Learning To Bleep


  • BC Advisor
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:01:15 AM

Posted 04 August 2009 - 10:29 PM

This error comes when you have disabled System Restore service AND have not turned off System Restore from System Properties.

Resolution:

1. Open StartMenu > Run and type services.msc and press Enter. A window titles Services would open.
2. In this, llocate System Restore Service service and double-click on it. A properties dialog box would open up.
3. In the Properties box, change Startup Type to Automatic and click OK to close the dialog box.

Now you can turn off System Restore from System Properties. Right click on My Computer and select Properties. Then select System Restore tab and turn off System Restore.

Once you have turned off the System Restore, you can disable System Restore service as well.

#3 lazybones09

lazybones09
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:15 PM

Posted 04 August 2009 - 10:55 PM

thank you

#4 lazybones09

lazybones09
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:15 PM

Posted 05 August 2009 - 11:20 PM

hey turns out the "start up type" is already set on "automatic".. so what do i do then because the same error message appears when i try to turn off system restore..

#5 Stang777

Stang777

    Just Hoping To Help


  • Members
  • 1,821 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:12:15 AM

Posted 05 August 2009 - 11:30 PM

How are you trying to turn it off?

Have you turned it off for each individual drive?

How much free space do you have on your harddrive?

#6 Romeo29

Romeo29

    Learning To Bleep


  • BC Advisor
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:01:15 AM

Posted 06 August 2009 - 10:50 AM

Your System Restore settings may have become corrupted. You may need to re-install System Restore :

1. Put your Windows XP CD in the CD drive. It may be needed (not if Windows finds necessary files on hard disk itself).
2. Open Start Menu > Run
3. Copy paste the following and press Enter :
rundll32.exe advpack.dll,LaunchINFSection %Windir%\Inf\sr.inf


#7 lazybones09

lazybones09
  • Topic Starter

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:02:15 PM

Posted 07 August 2009 - 11:18 PM

after inserting my windows xp cd and entering the code a window appeared containing the message "the file system sr.sys on windows xp home edition service pack 2 is needed" what does this mean?

#8 Romeo29

Romeo29

    Learning To Bleep


  • BC Advisor
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:01:15 AM

Posted 08 August 2009 - 05:19 AM

It means that you have to insert Windows XP Home edition CD with SP2.
You have inserted wrong CD - with wrong version of Windows or with wrong service pack.

Edited by Romeo29, 08 August 2009 - 05:20 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users