Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

avgold and explorer errors


  • Please log in to reply
3 replies to this topic

#1 dadintrouble

dadintrouble

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:03:41 PM

Posted 13 July 2005 - 10:08 PM

My daughter got the avgold virus last night and now I can't use either internet explorer or windows explorer to get rid of the virus or save her files. Windows explorer comes back with page fault errors. Has anyone else had this problem and knows how to fix it. Any assistance would be greatly appreciated. The system is a laptop IBM600e running windows98.

BC AdBot (Login to Remove)

 


m

#2 Chuckrox8

Chuckrox8

  • Members
  • 92 posts
  • OFFLINE
  •  
  • Local time:03:41 PM

Posted 13 July 2005 - 11:51 PM

Yes I was infected with AVGold just yesterday actually. Look in the spyware forum. A little below this one and you'll find an excellent guide to get rid of it. I was using Win98 SE. I couldn't use Windows Explorer or IE at all. I was thankfully somehow able to use AOL(not my computer, hate AOL) to email myself the files necessary to get rid of AVGold. It's weird. They want you to pay for it yet it blocks you from accessing IE. I'll post a link one sec.

#3 Chuckrox8

Chuckrox8

  • Members
  • 92 posts
  • OFFLINE
  •  
  • Local time:03:41 PM

Posted 13 July 2005 - 11:53 PM

http://www.bleepingcomputer.com/forums/How...old-t22397.html

You're going to have trouble if you can't access the net at all. You'll need 3 files: KillBox, HijackThis, and the registryfix. Hope you can work it out.

#4 gadrin

gadrin

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:03:41 PM

Posted 16 July 2005 - 02:49 PM

I got hit with Anti-Virus Gold/AVGOLD and the SmitFraud, but the instructions (while very handy) weren't quite up to date.

I was able to "disinfect" though by some perserverance using the programs and the helps/hints listed above.

FYI...

after following the instructions I still found these files on my computer:

C:\WINNT\system32\abirvalg.dll
C:\WINNT\system32\abirvalg32.dll
C:\WINNT\system32\svcnt.exe

C:\WINNT\system32\intel32.exe
C:\WINNT\system32\wp.bmp


C:\WINNT\system32\wininet.dll

all of which were created/modified with the time/date I got the infection (I knew right away and shutdown immediately...but...)

so I deleted those I could by hand, had to use the TASK MANAGER to stop those in use and delete. KILLBOX worked on the rest, all EXCEPT winInet.dll, which I couldn't delete no matter what.

however, after several reboots (using KILLBOX) I just now, as I type got my computer back to normal, including my DESKTOP tab on my display.

I also found the following registry entries via HIJACK THIS:

R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = res://C:\WINNT\system32\shdocsv.dll/API32.htm#ID=347;065D

R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant = res://shdocsv.dll/asst.htm

I think KILLBOX thru me for a loop, as I thought cutting & pasting the list would take care of all of them in one fell swoop. By the time I used the SmitFraud instructions, it didn't seem to work at all, so I had to

cut & paste
kill and reboot

one by one.

So, I'll monitor my PC for a few days and check back and let you know how it's going...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users