Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Missing HAL.DLL & Recovery Console password problem


  • Please log in to reply
1 reply to this topic

#1 seahawkrob

seahawkrob

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:07:06 AM

Posted 02 August 2009 - 08:42 PM

Hi, my mother has a 3 year old XP Professional computer that she's having some serious issues with. It's a Gateway that came with XP Pro installed. After a recent Windows update (set to automatically download), I restarted after being prompted to, and haven't been able to start Windows since. I get the following error message:

Windows could not start because the following file is missing
or corrupt:
<Windows root>/system32/hal.dll.
Please re-install a copy of the above file.

(note: there is a split-second mention of the BOOT.INI file just before the previous message is displayed. It's not on the screen long enough for me to read it all though)

Now, I spent a lot of time searching the Internet for this error and I found many indications that this is likely tied to IE8, and that uninstalling IE8 might help for the time being. Every discussion I've found, however, recommends using the Recovery Console tool to fix the current hal.dll problem, so that I can log in and fix the larger issue. I'm unable to access the Recovery Console, though, because I can't get passed the Administrator Password prompt. I've been using a Dell XP disc, since she can't find her Gateway disc. I'm still able to boot from the CD and get to the Recovery Console option. I've tried the two administrator passwords used on the computer (one for myself and another for my mother's account) and I've also simply hit Enter without entering anything, but nothing works. After three attempts, I'm prompted to restart the computer.

I've been searching the Internet for this issue now, and it seems that a fix from MS might work. Here's the link to the Microsoft Help and Support article: http://support.microsoft.com/default.aspx?...kb;en-us;308402. This article mentions a Q308402 hotfix, but states that I have to contact MS in order to obtain it. I've tried calling, but Microsoft wants me to pay for support before even hearing what the problem is. If I have to, I'll pay to get this fixed, but I'd rather not fork over more $ to MS if all this was started by installing one of their updates. Now, they do include this note on that same page:


Note In special cases, charges that are ordinarily incurred for support calls may be canceled if a Microsoft Support Professional determines that a specific update will resolve your problem. The usual support costs will apply to additional support questions and issues that do not qualify for the specific update in question.


...but it seems as if I'm going to get charged initially.

Are there any other options to get around this password issue? I've tried repeatedly to log into the Recovery Console, but I haven't had any luck at all. As mentioned, I'll pay the ransom to Microsoft if that's my only option, but I thought I'd ask around first.

Thank you very much!

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,874 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:06 AM

Posted 03 August 2009 - 08:22 AM

http://www.kellys-korner-xp.com/xp_haldll_missing.htm

Scroll down to Hal.dll Is Missing comments by Alex Nichol.

Another approach: http://pcsupport.about.com/od/findbyerrorm...ssinghaldll.htm

Microsoft guidance: http://support.microsoft.com/kb/314477

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users