Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

INternet connected but no pages come up


  • Please log in to reply
8 replies to this topic

#1 ndntank

ndntank

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:08:21 PM

Posted 02 August 2009 - 11:44 AM

Hi I run windows XP home edition all security updates with zone alarm free firewall, trend micro anti virus and spysweeper. When I try to open firefox or explorer, no web page appears. Explorer gives error message and gives me the option to run a diagnostic. I run it and it tells me to try opening Http port, https port and ftp port, or at least make sure they're open. I did and they are and still no web pages show up. Computer seems fine otherwise. Anyone have any suggestions?

Thanks
Ndntank

BC AdBot (Login to Remove)

 


#2 KonamiYoto

KonamiYoto

  • Members
  • 86 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:08:21 PM

Posted 02 August 2009 - 04:05 PM

Hello,

When Firefox is open, click on File and see if the Work Offline option is checked.
If yes, un-check it. Then try to re-connect to the internet.


~Zane

#3 mike171562

mike171562

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:08:21 PM

Posted 05 August 2009 - 09:56 AM

You can tell if you have port 80 open by opening a DOS prompts, Click start then run, type "cmd" and press OK. Then in the command window type "telnet google.com 80" If the screen goes blank with a blinking cursor, type "get" and press enter, you will see only html code, but it does mean that port is open if you get an error about connecting or timout then that port is closed check your firewall settings.

#4 Romeo29

Romeo29

    Learning To Bleep


  • BC Advisor
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:08:21 PM

Posted 05 August 2009 - 10:38 PM

Have you checked that DNS servers are set correctly?

Open StartMenu > Run and type cmd
In command prompt, type ipconfig /all and press enter.
You will see DNS servers listed.

Try pinging them, if DNS server is 208.67.222.222, type ping 208.67.222.222 if you get a reply from it, its working fine.

Next check if Zonealarm is configured properly and all network is not locked.

#5 ndntank

ndntank
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:08:21 PM

Posted 06 August 2009 - 08:41 PM

hey mike171562, ok I tried the telnet thing and when i tried to type "get" it popped me back to regulas command prompt. I'm guessing the port 80 is closed but don't know how to open it thru zone alarm. You've been a great help... any more suggestions?

Thanks

#6 Romeo29

Romeo29

    Learning To Bleep


  • BC Advisor
  • 3,194 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:127.0.0.1
  • Local time:08:21 PM

Posted 07 August 2009 - 05:27 AM

hey mike171562, ok I tried the telnet thing and when i tried to type "get" it popped me back to regulas command prompt. I'm guessing the port 80 is closed but don't know how to open it thru zone alarm. You've been a great help... any more suggestions?

Thanks


Did telnet connect to google.com? After connect what did it say?
And its port 80 of google.com servers, not yours. You don't have to open port 80.

Check what happens when you disable ZoneAlarm? Can you access websites?

#7 mike171562

mike171562

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:08:21 PM

Posted 07 August 2009 - 08:30 AM

If 80 is blocked he will definitely have to open it. Firewalls block outbound ports as well as inbound. Just like some ISP's block outbound connections on port 25. This prevents some people from connecting to their email server. If you did a telnet to port 80 on google.com and you got an error like 'connection failed' or 'could not open to connection to host on port 80' then your firewall has blocked that port for whatever reason. If you got a blank screen with a flashing cursor you should be able to type 'get' or 'quit' and see html. If its your firewall. Try turning your firewall of and see if that makes a difference.

#8 ndntank

ndntank
  • Topic Starter

  • Members
  • 19 posts
  • OFFLINE
  •  
  • Local time:08:21 PM

Posted 07 August 2009 - 04:39 PM

ok, in dos, I typed "telnet google.com 80" Screen goes blank with a blinking cursor in top left corner. I start to type "get" and when I hit the "g" key the dos prompt " c:/document /user etc. etc." comes up. I tried the same thing with my laptop and it brought up the html code like it was supposed to so I assumed the port was closed. Also something that might be related, my windows media player starts to play a CD then becomes unresponsive... could I have a virus that shuts off access to internet, then starts trashing programs?

#9 mike171562

mike171562

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:08:21 PM

Posted 11 August 2009 - 08:33 AM

ndntank, could be corrupt winsock settings. try doing a winsock reset. in a DOS prompt type 'netsh winsock reset' and reboot the computer.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users