Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

PSU High Pitch Noise


  • Please log in to reply
1 reply to this topic

#1 stghm

stghm

  • Members
  • 10 posts
  • OFFLINE
  •  
  • Local time:11:26 PM

Posted 25 July 2009 - 01:21 AM

When I have the power plugged in and the switch on, but the system is powered down the PSU emits a high pitch ringing noise. It kind of pulsates, but it seems to go away when I power it on. Is it something that can be fixed or do I need to RMA?

BC AdBot (Login to Remove)

 


m

#2 fairjoeblue

fairjoeblue

  • Members
  • 1,594 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:11:26 PM

Posted 25 July 2009 - 01:34 AM

If you can RMA it you might want to do that !
OCZ StealthXstream 700W,Gigabyte GA-EP45-UD3R , E8500, Arctic Freezer Pro 7, 3GB G.Skill PC8500,Gigabyte Radeon HD 4850 OC [1GB ], Seagate 250GB SATA II X2 in RAID 0, Samsung SATA DVD burner.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users