Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

User Interface Failure


  • Please log in to reply
3 replies to this topic

#1 G_Man8904

G_Man8904

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:12:02 AM

Posted 20 July 2009 - 05:00 PM

When I turn on the laptop (HP Pavillion dv6000) the following occurs:
1. The HP symbol appears.
2. Then the Windows screen appears.
3. The computer appears to be logging me in and going to the desktop (as normal), but before doing so, encounters the following error message:

User Interface Failure

The Logon User Interface DLL msgina.dll failed to load. Contact your system administrator to replace the DLL, or to restore the original DLL.

The box has a button at the bottom the says "Restart". When I try to close the box the message does not disappear.

I have attempted to start the computer in safe mode, safe mode with networking, and safe mode with command promt. I've also tried Last Known Good Configuration, directory services restore mode, and debugging mode. None of these allow me to go past the error message.

I am currently on the first day of a two week vacation and do not have any of the software or reboot discs that came with my laptop. I appreciate any help that you can provide in this matter.

BC AdBot (Login to Remove)

 


m

#2 hamluis

hamluis

    Moderator


  • Moderator
  • 54,848 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:02 PM

Posted 20 July 2009 - 05:46 PM

Worth reviewing:

http://support.microsoft.com/kb/836683

http://technet.microsoft.com/en-us/library/bb742447.aspx

Louis

#3 joseibarra

joseibarra

  • Members
  • 1,021 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:11:02 PM

Posted 20 July 2009 - 05:57 PM

It sounds like you have tried all the usual things that are referenced in articles.

Are you sure you tried Last Known Good?! :thumbsup: No Safe Mode?

I did find one article that looks like a good and safe idea and assumes some possible file corruption and you don't have any CDs with you, so can you burn a CD to create a bootable Recovery Console CD?

There are most likely other copies of the files on your HDD and the suspicious ones can be replaced with the copies.

I will borrow hints with credit to Amazing Andrew!

Download the xp_rec_con.iso file from here:

http://www.mediafire.com/?ueyyzfymmig

I used the ImgBurn program referenced in the following link - worked first time:

http://www.bleepingcomputer.com/tutorials/write-a-cd-dvd-image-or-iso/

Boot on the CD, make the obvious choices and responses to end up at what appears to be a command prompt.

Here is the article that makes sense and attempts to resolve the problem using Recovery Console to replace suspicious files with copies that should already be on your HDD. I looked and they are on my system where indicated:

http://supportwiki.cisco.com/ViewWiki/inde...e_original_DLL_.

Moving around in RC is different than what you may be used to in your regular DOS prompt. I found it frustrating at first and thought something was wrong, but it was me.

Spaces and backslashes to change directories and copy that are in the instructions look right.

This may not resolve your issue. But you will also won't make things any worse. Nothing gets deleted so you can always go back.

I imagine other ideas will be forthcoming, so you may want to accumulate a few and choose what sounds the best.

Edited by joseibarra, 20 July 2009 - 06:37 PM.

The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.


#4 joseibarra

joseibarra

  • Members
  • 1,021 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:11:02 PM

Posted 20 July 2009 - 06:02 PM

The article link does not appear to work (too long?) so here is the gist. It also doesn't paste worth a hoot.



Title The user receives error message The Logon User Interface DLL Msgina.dll failed to load. Contact your system administrator to replace DLL or restore the original DLL .

Core Issue
This is due to the installation of Microsoft Windows updates, any new software, or Service Pack for IE. Some critical files failed to be copied to the Windows\System32 folder during the installation of any software mentioned or SP1 (including shlwapi.dll and msgina.dll). The Winlogon process is updated by SP1.When winlogon.exe runs, looks for these dlls, and finds mismatched versions, it fails to execute. As a result, XP fails to load. The msgina.dll file is required by the Winlogon service.

Resolution
The DLL file is msgina or msgina.dll. The DLL name isWindows NT Logon GINA DLL

Msgina.dll is a module loaded by Winlogon to implement the authentication policy. The file performs all user identification and authentication interactions.To resolve the issue, perform these steps :

1.Boot to recovery console.
2. Type these commands

cd system32 [enter]
ren winlogon.exe winlogon.old
ren msgina.dll msgina.old
ren shell32.dll shell32.old
ren shlwapi.dll shlwapi.old

cd.. [enter]
cd servicepackfiles\i386 [enter]
copy MSGINA.DLL c:\windows\system32
copy SHELL32.DLL c:\windows\system32
copy WINLOGON.EXE c:\windows\system32
copy shlwapi.dll c:\windows\system32

The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users