Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Did my computer get fried?


  • Please log in to reply
1 reply to this topic

#1 Walter Jones

Walter Jones

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:05:25 AM

Posted 19 July 2009 - 10:47 PM

Yesterday there was a bad storm with alot of lightning, when I got home from work my computer nor my modem were working. I unplugged the overnight and tried this morning and still they were not working. I went around my apartment and resest all of the switches and the plugs, and I reset my breakers. I can't understand what happened to my computer or modem because both of them are plugged into a surge protector? I also notice that when I plug in my computer the light on the motherboard comes on then turns off after a couple of seconds, I also tried reseating the battery on the motherboard and still nothing happens! Does anybody have any ideas??

BC AdBot (Login to Remove)

 


#2 fairjoeblue

fairjoeblue

  • Members
  • 1,594 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:04:25 AM

Posted 20 July 2009 - 01:02 AM

It sounds like your stuff is the victim of a lightning strike somewhere.

The kind of surge protectors most people use aren't as good as most think.

You may get lucky & put a new power supply in your computer & it still work .
OCZ StealthXstream 700W,Gigabyte GA-EP45-UD3R , E8500, Arctic Freezer Pro 7, 3GB G.Skill PC8500,Gigabyte Radeon HD 4850 OC [1GB ], Seagate 250GB SATA II X2 in RAID 0, Samsung SATA DVD burner.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users