Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Command Prompt Copy Question


  • Please log in to reply
2 replies to this topic

#1 Alterah

Alterah

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:38 PM

Posted 18 July 2009 - 09:11 PM

Usings Windows XP Media Center Edition SP2

I thought I understood how to do this, but I am obviously missing something. I am wanting to copy a file called TODO.txt from the following directory:
C:\Documents and Settings\Owner\Desktop

To the following Directory:
C:\Documents and Settings\

So I used the following command to go to the correct directory:
cd C:\Documents and Settings\Owner\Desktop

I use DIR to varify that the file is the directory I am in. Then I use the following command to make the copy:
Copy TODO.txt C:\Documents and Settings\

But, it seems the syntax is incorrect for that. I was,however, able to successfully copy the file to C:\ using "Copy TODO.txt C:\"

Anyhow, I could go through the various commands I have tried, so I figured I would try the following:
Copy C:\Documents and Settings\Owner\Desktop\TODO.txt C:\Documents and Settings\TODO.txt

I get "The system cannot find the file specified"

So, I am at a loss. Everything I read tells me to essentially do the following:
Copy Source File Destination File

Thanks for reading through all that and for any help. Also, I apologize if this is in the wrong place, which it appears it might be.

Edited by Alterah, 18 July 2009 - 09:13 PM.


BC AdBot (Login to Remove)

 


m

#2 Alterah

Alterah
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:38 PM

Posted 18 July 2009 - 10:11 PM

It appears my problem was simply not putting quotes around where I wanted the file copied to...I don't think I saw that in any guide I saw.

#3 Grinler

Grinler

    Lawrence Abrams


  • Admin
  • 43,395 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:04:38 PM

Posted 20 July 2009 - 08:19 AM

Yup, when you reference a path that contains spaces you need to put quotes around it. Otherwise the command will the see the words after a space as arguments.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users