Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Black screen logging into admin account & hanging UAC dialog


  • Please log in to reply
No replies to this topic

#1 Cetaphil

Cetaphil

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:47 PM

Posted 09 July 2009 - 02:16 PM

Vista Home Premium
Service Pack 1

Bear with me a me on this, as it is my friend (who doesn't speak English very well) who is having this issue and I do normally work on a Vista machine. I will try to interpret everything she says here.

The computer has two accounts on it, one has administrator privileges and the other is a user account that belongs to her son. Whenever she tries to log into the admin account, after entering her password, the screen goes black. We managed to circumvent the black screen and reveal the desktop by bringing up the task manager with control + alt + del, then ending and restarting explorer.exe.

Her son's account logs in and works fine.

The second problem (and I'm not sure if they are related) which ties our hands from diagnosing/resolving the first is that she's unable to access any system tools or run any files which require elevated security. She can't install anything or run anything with the security icon on the admin account (her son's user account has heavy parental controls enabled so attempting to install/run anything from there is a moot point.) The UAC prompt which is supposed to come up when trying to access these things never does. She gets the Vista spinning blue "working/please wait" mouse animation instead and nothing else.

We think the problem happened occurred after the last Windows update, somehow something was corrupted, because there were no other recent changes to her system (the computer has been in storage for a week.)

We've tried:
  • Disabling the UAC but we can't because that also requires you to enter your admin password via UAC prompt.
  • A system restore, but the problem still persists.
  • We tried running a virus scan but Vista's LiveCare won't run and we can't install any other scanners because of UAC.
I found this as a fix for the black screen issue on another site, but shes unable to run regedit.

This fixed my blank screen at login issue!!!

My issue was forcing me to Ctrl+Shift+Esc to manually Run 'Explorer' to find my desktop.
My registry entry was invalid.
Under 'Shell" i changed the string from: Explorer.exe C:\WINDOWS\Config\csrss.exe To Explorer.exe
After a reboot my computer loaded normally.


What is the best course of action now? I have read a couple of threads with semi-similar issues suggesting:
  • Resetting the security to default settings on the admin account using the script on the MS site here: http://support.microsoft.com/kb/313222, but I'm afraid to do this if it might wipe out her son's account (they're in the process of backing up files.)
  • Going through each of the processes in the service dialog and disabling them one by one to see if any one is corrupted (UAC won't let her.)
Any other suggestions appreciated.

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users