Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

High CPU usage?


  • Please log in to reply
8 replies to this topic

#1 golfdude

golfdude

  • Members
  • 219 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ft Wayne, Indiana
  • Local time:09:17 AM

Posted 08 July 2009 - 08:23 AM

Is there a way to disable wmpnetwk.exe, or stop it from using so much of my CPU? I have stopped the process in Task Manager but it starts up again all by itself. Sometimes when it is running it is using 25% of my CPU and over 2 gigs of RAM. I have Windows 7 Ultimate.
Is there any settings I can change to control this?

Thanks,
Golfdude

America is all about speed. Hot, nasty, badass speed. -Eleanor Roosevelt, 1936
Intel i7-3820, 32 GB DDR3-1600, Intel 330 SSD Boot Drive, WD 3TB Data Drive, Radeon HD7770 GHz Edition, Windows 10 Professional 64 Bit
 


BC AdBot (Login to Remove)

 


#2 andrewww

andrewww

  • Members
  • 111 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Glasgow
  • Local time:02:17 PM

Posted 13 July 2009 - 08:04 AM

25% of CPU isnt too bad and i normally use around 1.28GB of RAM on this vista machine at work idle. Can remember what 7 runs at, will check when im home!
Lucy
C2D E6600 @ 2.4, 8GB OCZ Reaper @ 1066, 500GB Barracuda, Powercolor HD4850, Asus P5Q Pro, Corsair TX650, NZXT Lexa Blackline, Windows 7 - Build 7100, Samsung 22" Monitor

#3 golfdude

golfdude
  • Topic Starter

  • Members
  • 219 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ft Wayne, Indiana
  • Local time:09:17 AM

Posted 13 July 2009 - 02:08 PM

To clarify- the (1) process (wmpnetwk.exe) alone is using that much of my resources. When the process is running my RAM usage sometimes is peaking over 80% and my CPU- all 4 Cores can be over 75%. I know the process has to do with Windows Media Player from another website, but it doesn't explain the rediculous resource usage. One thread I read stated this was a problem with WMP 11 and switching back to WMP 10 stopped this from happening.

The other day I changed the wmpnetwk.exe process to "Manual" instead of "Automatic (Delayed start)" in my system services. This didn't help, so I disabled the Recovery actions and it hasn't happened again. The wmpnetwk.exe somehow went back to "Automatic (Delayed Start)", however, the Recovery actions are still disabled. Anyway, I haven't had any problems with the resources going crazy since I did this.

I have had problems with my wireless internet connection lately and from reading information on my ISP's forum (Verizon), there may be a problem with the wireless router they provided me. The guy who started the thread was claiming it was a problem with FiOS and Windows Vista. I didn't have any real problems with running Vista and FiOS, but the intermitant connection problems have gotten worse lately. I did switch my OS to Windows 7- 64 bit a few weeks back, but in the Verizon thread people who were having this problem were cured when they bought a decent wireless router and disabled the wireless on the router that Verizon provided.

Anyway, at this time the problem has gone away, but I appreciate you taking the time to respond.

Thanks,
Golfdude

America is all about speed. Hot, nasty, badass speed. -Eleanor Roosevelt, 1936
Intel i7-3820, 32 GB DDR3-1600, Intel 330 SSD Boot Drive, WD 3TB Data Drive, Radeon HD7770 GHz Edition, Windows 10 Professional 64 Bit
 


#4 golfdude

golfdude
  • Topic Starter

  • Members
  • 219 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ft Wayne, Indiana
  • Local time:09:17 AM

Posted 19 July 2009 - 05:58 PM

Still looking for some help here and if anyone else is having this problem.

When "wmpnetwk.exe" goes crazy, this is the status of my CPU/RAM:

Posted Image

After shutting down "wmpnetwk.exe" in Task Manager, this is my status:

Posted Image

I would like to quit opening Task Manager everytime this happens.

Any ideas?

Thanks,
Golfdude

America is all about speed. Hot, nasty, badass speed. -Eleanor Roosevelt, 1936
Intel i7-3820, 32 GB DDR3-1600, Intel 330 SSD Boot Drive, WD 3TB Data Drive, Radeon HD7770 GHz Edition, Windows 10 Professional 64 Bit
 


#5 exile360

exile360

  • Members
  • 100 posts
  • OFFLINE
  •  
  • Local time:08:17 AM

Posted 20 July 2009 - 06:00 AM

Greetings :huh: .

If you don't do any kind of media sharing (like music and videos) via Windows Media Player with other computers on your network or an XBox360 then you can disable it. You'll have to access the options under Library in Windows Media Player and turn off media sharing as well as disable the service.

To disable the service:
  • Click the Start Orb and type services.msc and press enter
  • Click Continue if User Account Control pops up
  • Find the service called Windows Media Player Network Sharing and double click it
  • Click the drop down menu next to Startup Type and select Disabled
  • Click the Stop button
  • Click the Apply button
  • Click the Ok button and close the Services manager


#6 golfdude

golfdude
  • Topic Starter

  • Members
  • 219 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ft Wayne, Indiana
  • Local time:09:17 AM

Posted 20 July 2009 - 06:52 AM

Exile360,

Thank you for replying to my post.

You'll have to access the options under Library in Windows Media Player and turn off media sharing


I am not sure where this option is... I have opened WMP and can not find the media sharing option is. This is what I have:

Posted Image


To disable the service:

  • Click the Start Orb and type services.msc and press enter
  • Click Continue if User Account Control pops up
  • Find the service called Windows Media Player Network Sharing and double click it
  • Click the drop down menu next to Startup Type and select Disabled
  • Click the Stop button
  • Click the Apply button
  • Click the Ok button and close the Services manager

I have done this and the darn thing starts back up on its own!!!!

Maybe I am not doing it right. Let me know if I am not understanding your instructions.

Thanks,
Tom

Thanks,
Golfdude

America is all about speed. Hot, nasty, badass speed. -Eleanor Roosevelt, 1936
Intel i7-3820, 32 GB DDR3-1600, Intel 330 SSD Boot Drive, WD 3TB Data Drive, Radeon HD7770 GHz Edition, Windows 10 Professional 64 Bit
 


#7 exile360

exile360

  • Members
  • 100 posts
  • OFFLINE
  •  
  • Local time:08:17 AM

Posted 20 July 2009 - 11:57 AM

Sorry about that, my mistake. It should be on the Network tab. Just for info, I've seen users disable it this way and it worked but I had to go a bit further and actually change the security policies on the file to deny execution of the file by any user on my system. Hopefully you won't have to go that far though ;) .

edit: I found further info for you here stating that you might also need to disable the media sharing options in the Network and Sharing Center befor it will stop trying to run.

Edited by exile360, 20 July 2009 - 12:03 PM.


#8 golfdude

golfdude
  • Topic Starter

  • Members
  • 219 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ft Wayne, Indiana
  • Local time:09:17 AM

Posted 20 July 2009 - 12:28 PM

Thanks for the reply. I followed the link you sent me and hopefully have this taken care of. I chose "Block all" and then disabled wmpnetwk.exe and stopped the service. I will post back if it comes back again. :huh:

Thanks,
Tom

Thanks,
Golfdude

America is all about speed. Hot, nasty, badass speed. -Eleanor Roosevelt, 1936
Intel i7-3820, 32 GB DDR3-1600, Intel 330 SSD Boot Drive, WD 3TB Data Drive, Radeon HD7770 GHz Edition, Windows 10 Professional 64 Bit
 


#9 exile360

exile360

  • Members
  • 100 posts
  • OFFLINE
  •  
  • Local time:08:17 AM

Posted 21 July 2009 - 12:29 PM

You're very welcome :huh: . I had similar issues with WMPNSConfig in Vista (it's a program that serves the same purpose as WMPNetwork in 7) and I had to take extreme measures to always prevent it. I can guide you on how to do so, but for now I'll leave it alone. Hopefully that last step you did took care of it, if not let me know and I'll give you the nuclear option :huh: .

Take care :D .




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users