Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Limited or No Connection


  • Please log in to reply
4 replies to this topic

#1 uemike

uemike

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:15 PM

Posted 02 July 2009 - 09:47 PM

Hello,

I searched for information on this topic, but I couldn't find anything specific to my problem. I'll try to be as detailed as possible.

Win XP
1G RAM
1.2 ghz Athlon processor
onboard network adapter

This morning I was working away with Firefox, Chrome and and older version of IE running. I was creating a graphic for my website in a program called Fireworks (it came with Dreamweaver) - in other words I wasn't doing anything out of the ordinary.

All of a sudden, everything bogged down to a crawl and Chrome, FF and Fireworks all were 'not responding'. The mouse pointer would not move but the PC was still active (making noise). After about 10 minutes after I initiated closing of all four programs through the task mgr, it finally closed them and everything caught up. I restarted the machine since it'd been a few days anyhow and I thought it would be a good idea.

Upon restart, everything was considerably slower than usual and Firefox would not try to find web pages. I didn't get the normal error screen, the new tabs simply remained a blank white screen. When I rebooted, the antivirus ran because I had downloaded the updated version of AVG but this was the first time I'd rebooted since install. It found a couple of adware programs which I deleted.

This was when I noticed the "Limited or no connectivity" icon in the sys. tray.

I rebooted again and Firefox will now attmnpt to find webpages but I always get the error message. I run the internet connection through a cable modem through a router. I reset the modem and router - no change in condition.

I called my ISP and verified that the modem was working - it is. The tech had me perform an ipconfig test and it gave a 169. code. The tech told me the problem was local to my pc.

There are two computers in the house off of the same router. I plugged the ethernet cable directly fron the modem to the PC, again no change in condition. I verified that the other PC has internet connectivity through the router, which it does.

At the advice of a friend, I attempted to 'release' the ipconfig through the dos prompt. Doing so changed it from a 169. to a 0.0.0.0 ip address - still no connectivity. I played with some of the settings in the network adapters, including the 'speed and duplex' - no change.

I tried to repair the connection, did not work. The network adapters are functioning properly according to the device manager.

I thought maybe there was a problem with the new AVG, so I deleted the program (the uninstaller did nothing). I also deleted the old version of AVG as well. Rebooted and retested, still nothing.

I disabled zone-alarms. No change.

The problem as I understand it is that there is no connectivity because it will not release the ip address.

The computer has been somewhat sluggish as of late - but not too bad overall. It's an old machine and I push it pretty hard, running two monitors and somewhat resource heavy graphic editing applications. I find it hard to believe that this is a hardware problem due to the nature of how the problem occurred. About the only thing I haven't done is tried a new ethernet cable - the reason is that the PC in question is in the basement and the router is in the 2nd story office on the opposite end of the house. I have an ethernet cable routed through the house to the pc in the basement. It isn't practical to try to change it.

Thanks a lot - I appreciate all the help I can get!!

Mike

BC AdBot (Login to Remove)

 


m

#2 case.bolt

case.bolt

  • Members
  • 190 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:15 PM

Posted 02 July 2009 - 10:57 PM

How is your home network configured? Have you assigned static IPs or do you use a local DHCP range of addresses?

a 169.x.x.x ip indicates that your NIC has not grabbed a valid IP... so if you use static IPs make sure the connection is set with the correct static IP. Generally, if you are set with static IPs, and you end up with a 169.x.x.x it means your connection has failed before it reaches the CPU (bad patch cable/router port/router/cable/modem in that order)

However, if you use DHCP, a 169.x.x.x would normally indicate a failure for the machine to obtain a valid IP from the DHCP service. Since your other comp is working fine, the router is most likely not the problem if this is the case.

Since your IP is now 0.0.0.0, check out this article: http://support.microsoft.com/kb/822123

Diagnosis:
1. DHCP Service not running.
2. Duplicate IP address on the network.
3. Bad NIC card drivers.
4. Defective NIC hardware.
Resolution:
1. Check Control Panel, Administrative Tools, Services. The DHCP Client service should be Started and its Startup Type should be Automatic.
2. Turn off ALL of the computers and other network connected devices, restart (power cycle) the router, then restart all the computers and other network devices.
3. Check for upgraded drivers and/or reload the Network drivers.
4. Replace the Network Interface Card.

You can also try resetting your protocol stacks.

Go Start--->Run then type CMD and press enter. Type the following commands (in bold) into the Dos prompt that opens.

Reset TCP/IP stack to installation defaults, type: netsh int ip reset reset.log

Reset WINSOCK entries to installation defaults, type: netsh winsock reset catalog

Give all that a shot. none of it should have any bad consequences if it doesn't fix the problem. If all else fails, try swapping out your known working computer's NIC with the bad one.. if it works, buy a new NIC :thumbsup:

#3 hamluis

hamluis

    Moderator


  • Moderator
  • 54,865 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:15 PM

Posted 03 July 2009 - 10:12 AM

FWIW: When I have encountered the "limited or no connectivity" situation, I either set the connection up anew or added the NetBIOS protocol to one of my systems (I have two systems and the problem usually manifested itself on only one).

I haven't had a problem with such since I now enable the NetBIOS protocol as part of my install routine.

Louis

#4 uemike

uemike
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:15 PM

Posted 03 July 2009 - 11:36 AM

Case.Bolt,

I printed off your post and ran through the list. I did EVERYTHING you suggested. The last thing I looked at was the device mgr - the onboard network adapter was disabled. I checked yesterday afternoon and unless I overlooked it, this was not the case.

I enabled the device and rebooted and now everything is good.

I just wanted to say thanks for taking the time to post such a detailed response. I really appreciate it.

Mike

#5 case.bolt

case.bolt

  • Members
  • 190 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:04:15 PM

Posted 03 July 2009 - 02:39 PM

Hey, that's great, glad I could help. It's odd that your NIC was disabled randomly... I'd keep an eye on that in the near future, and keep an eye out for any erratic behavior form your NIC/Network as random disabling may indicate a larger problem. then again, it might just be one of those great unexplainables that sometimes happen :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users