Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Faulting application spoolsv.exe


  • Please log in to reply
2 replies to this topic

#1 hm2k

hm2k

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:12:04 AM

Posted 02 July 2009 - 05:45 AM

Faulting application spoolsv.exe, version 6.0.6001.18000, time stamp 0x4791956c, faulting module hpz3r4xa.dll, version 61.63.264.22, time stamp 0x46e0f6e2, exception code 0xc0000005, fault offset 0x00104a0d, process id 0x63c, application start time 0x01c9fae992cf95c6.

I get this when trying to print a pdf file to a HP Officejet K7100 Series printer from Adobe Reader on Windows Vista.

Any idea how to fix this error?

BC AdBot (Login to Remove)

 


m

#2 High500

High500

  • Members
  • 75 posts
  • OFFLINE
  •  
  • Local time:01:04 AM

Posted 02 July 2009 - 08:32 AM

Hi hmn2k

Ok well I have an XP approriate fix and it may just work for vista too so give it a whirl:

To fix spoolsv.exe application error, you will have to remove these files from the system. To do this, perform the following steps on your Windows XP computer:

Open Control Panel, select Performance and Maintenance, select Administrative Tools and then select the Services option.
In the Services management console, locate the Spooler services, right-click on it and select Stop.
Next, open the C:\Windows\System32\Spool\Printers folder. (Here, we are assuming that your Windows is installed in the default C:\Windows folder)
Delete all the .SHD and SPL files from this folder.
Next, open the TMP folder and delete all old and unused files from this folder.
Finally, restart the Spooler service from the Services management console.


Not sure how specific this may relate to your problem, or if it works on vista but it should be the same process.
Also i noted that spoolsv may not be the root cause and it may be a faulty hp driver (hpz3r4xa.dll). Have you tried uninstalling the printer and its drivers and re-installing?
That may also fix the issue.

Let me know how you get on!

High500

Edited by High500, 02 July 2009 - 08:34 AM.


#3 hm2k

hm2k
  • Topic Starter

  • Members
  • 5 posts
  • OFFLINE
  •  
  • Local time:12:04 AM

Posted 02 July 2009 - 09:44 AM

I used the following commands to fix the spooler...

@echo off
net stop spooler
del %windir%\system32\spool\printers\*.* /q
net start spooler

I tried reinstalling the drives twice, but there's been no updates since 2007, as you can see from this link:
http://h20000.www2.hp.com/bizsupport/TechS...p;swEnvOID=2093

I discovered that it printed fine when I used FoxIt Reader instead of Adobe Reader.

It's as if the spooler can't handle the data being sent from Adobe Reader or something... I've tried reinstalling it too.

Perhaps it's time to contact Adobe or HP? Not sure...




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users