Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Firefox 3.0 will not stay signed into websites


  • Please log in to reply
6 replies to this topic

#1 NZuck

NZuck

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:07 PM

Posted 28 June 2009 - 01:17 PM

Hello,

So I'm experiencing a problem with my Firefox browser. A google search revealed that a lot of people seem to be experiencing the same one -- so did a quick scan of the forum.

Firefox won't stay, despite clicking the 'stay logged in/signed in' button, into any website, such as, Flickr, Facebook, Hotmail and Gmail.

The steps I've already taken:

I've run spyware antivirus program (AVG, Window's new OneLiveCare thing, SUPERAntiSpyware, Windows Defender) and these seemed to have found and removed spyware.
I've uninstalled and reinstalled Firefox.
I've run Firefox in safe mode.
As per a Firefox help website instructions, i've looked for the file 'cookies.sqite' to delete it, but could not find it (Tools -> Options -> Privacy -> show exceptions for cookies but that file was not there)
I've cleared all my data.
And I've checked to see if any of these sits were on my save password exceptions list.

None of this works. What I find is that while the browser is open, if I navigate away from the site, I will stay logged in. However, once I 'X' the browser or 'File -> Exit' and reenter, it no longer stays signed in. I have IE on my computer and that does not seem to be experiencing any problems.

Any help with this would be very much appreciated.

BC AdBot (Login to Remove)

 


#2 csice

csice

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:01:07 PM

Posted 17 July 2009 - 03:29 PM

Sorry for bringing up an old thread, but I was going to make a similar one so...Anyways, I have the same problem except with Firefox 3.5, and have tried the same things, any suggestions?

#3 csice

csice

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:01:07 PM

Posted 19 July 2009 - 01:25 PM

One more bump for help please!

#4 Mysterysgames

Mysterysgames

  • Members
  • 159 posts
  • OFFLINE
  •  
  • Local time:07:07 PM

Posted 19 July 2009 - 06:17 PM

Hi csice,

From the descripton in the first post, your cookies might be set to be deleted when you close FireFox. Cookies are needed to stay logged in.
If you wish to stay logged in after closing FireFox, and starting it again, you can change the settings:
Tools -> Options -> Privacy
Then there is a "Settings" button next to "clear history when FireFox closes". Click on that "Settings" button, and uncheck "Cookies".

Does this help?

(I personally let FireFox delete my history and cookies when I close it for security reasons, and prefer to log in again when I restart FireFox.)

Edited by Mysterysgames, 19 July 2009 - 06:18 PM.


#5 csice

csice

  • Members
  • 21 posts
  • OFFLINE
  •  
  • Local time:01:07 PM

Posted 21 July 2009 - 01:19 PM

I'm afraid that didn't work either.

#6 bluesjunior

bluesjunior

  • Members
  • 761 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:07 PM

Posted 21 July 2009 - 01:30 PM

In Firefox click Tools>Options>Privacy choose "Use Custom Settings For History" option.
Motherboard: Gigabyte GA-MA770T-UD3, CPU: AMD Athlon II X3 450 Processor, Memory: OCZ 4GB (2x2GB) DDR3 1333MHz,Graphics: PowerColor HD 5750 1GB GDDR5,
PSU: Corsair 430W CX PSU 4x SATA 1x PCI-E, Hard Drive:Samsung SpinPoint F3 500GB Hard Drive SATAII 7200rpm 16MB Cache.

#7 Guest_wako944_*

Guest_wako944_*

  • Guests
  • OFFLINE
  •  

Posted 22 July 2009 - 12:06 AM

Hi NZuck, I've been experiencing the EXACT same problem as you and after looking around on the internet forever, I finally found a fix on the internet. The problem is that you have a corrupted cookies.sqlite file. So, all you have to do is delete it.

The file should be located here (it was for me running Vista 64-bit):

C:\Users\[Username]\AppData\Roaming\Mozilla\Firefox\Profiles\default

AppData only showed for me when I enabled "Show hidden files and folders"

This can be achieved by doing:

Press Alt -> Tools -> Folder Options -> View -> Hidden files and folders -> Show hidden files and folders

You can read up more here:

http://support.mozilla.com/tiki-view_forum...2&forumId=1

and

http://capetownnews.co.za/2008/07/22/losin...rowser-cookies/

Works like a charm :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users