Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

How do I disable onboard audio if it's not in the BIOS setup?


  • Please log in to reply
14 replies to this topic

#1 All Meshed Up

All Meshed Up

  • Members
  • 46 posts
  • OFFLINE
  •  
  • Local time:09:38 PM

Posted 26 June 2009 - 01:37 AM

ugh… I grow so very tired from this problem, so I'll try to make it short.

In order to get my external Audigy 2 ZS Notebook sound card to work properly I need to disable the on-board sound card (SigmaTel 9750) in the Bios setup on startup. Trouble is, it isn't there. All I see is options for my LAN, mini-PCI, and modem. Disabling or uninstalling the sound card from the device manager doesn't help. And yes, I have set the Audigy as my default device in the audio options.

I updated my Bios (which scared the crap out of me). But nothing changed.

Is there a wizard here who might possibly be able to help me? I just need to set my Audigy as the primary/only sound card.
"There must be someway out of here, Said the joker to the thief."

BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:10:38 PM

Posted 26 June 2009 - 09:20 PM

It might be listed in Onboard Peripherals. Change the Audio Chip to disabled.
Or in Advanced Options/Chipset Settings and change ICH Audio Codec to disabled
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#3 All Meshed Up

All Meshed Up
  • Topic Starter

  • Members
  • 46 posts
  • OFFLINE
  •  
  • Local time:09:38 PM

Posted 26 June 2009 - 10:30 PM

Yeah, I know it SHOULD be in onboard peripherals, but it's not. Only my LAN, MiniPCI, and modem are listed there.
I know that much...
...but what I don't know are these "advanced options" you're talking about. Where are they? I don't see anything for any other options then what I have right in front of me when I go into BIOS setup.
"There must be someway out of here, Said the joker to the thief."

#4 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:10:38 PM

Posted 27 June 2009 - 08:52 AM

Each computer manufacturer's BIOS is set up different, even though it may come from the same company
It's possible you might not have the option
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#5 All Meshed Up

All Meshed Up
  • Topic Starter

  • Members
  • 46 posts
  • OFFLINE
  •  
  • Local time:09:38 PM

Posted 27 June 2009 - 01:52 PM

sooooooo… what? That's it? There's nothing I can do?

Is there a different way to completely disable it? I found something on Goggle that mentioned it may being controlled by a dip switch, but no details were given. I've opened this notebook up once before and didn't see any cable I could disconnect. The damn thing doesn't even really work and I'm ready to rip it out… I know, I know, bad idea.

I have no problem going into the registry or anything, I've done that sort of thing many times before.
"There must be someway out of here, Said the joker to the thief."

#6 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:10:38 PM

Posted 27 June 2009 - 05:34 PM

What is the make/model of the laptop?

Edited by garmanma, 27 June 2009 - 05:34 PM.

Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#7 All Meshed Up

All Meshed Up
  • Topic Starter

  • Members
  • 46 posts
  • OFFLINE
  •  
  • Local time:09:38 PM

Posted 27 June 2009 - 09:48 PM

tis' a:
Dell Inspiron 9300 notebook
Windows XP Home SP2

Onboard Sound card is a:
Sigmatel 9750

External Sound Card is a:
Creative Audigy 2 ZS notebook

All of these are running on their most recent drivers and work just fine on their own. The problem is that the when I set the Audigy as the default sound card in the "sounds & Audio Devices" my speakers don't work. Everything I've gathered from the all mighty Google tells me that I need to disable the onboard card for this to be fixed, but as my luck would have it, I seem to be the only one who can't do this.
Many others say to look in the owners manual but there's no help there.
And again; disabling or uninstalling it through the device manager doesn't help.
"There must be someway out of here, Said the joker to the thief."

#8 starcraftmaster

starcraftmaster

  • Members
  • 1,109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:australia
  • Local time:01:38 PM

Posted 27 June 2009 - 11:19 PM

there heaps of motherboard that dont let you turn off the onboard sound
so creative are the dumb type lol
i had so meny probloms with creative crap
if it was me i would try to not buy creative

any way cant you set the audigy as audigy insted of default ?
and have you set the right speaker set up in windows sounds and multimedia in control panel ?

on the mother board there may be a jumper to turn off the onboard sound
thats how its done on my old packard bell

so look at the maunel

#9 All Meshed Up

All Meshed Up
  • Topic Starter

  • Members
  • 46 posts
  • OFFLINE
  •  
  • Local time:09:38 PM

Posted 28 June 2009 - 02:36 PM

Wow, dude, did you read my last post AT ALL?! If you're not going to pay attention don't try to help; and you could, at the very least, try to type properly.

Once more:
I DID set Audigy as default.
I DID set the correct speaker settings.
I DID look for a jumper and couldn't find one.
I DID look at the manual.

I know how to do this stuff, it's just this one thing that I can't figure out; and the one thing that I need to do to get this working.

And Creative makes the best sound cards out there, it's just the fact that they can't write a decent program to save their asses. I've already dealt with, and fixed, the problems inherit in using a Creative card. But if you'd bother to keep up with the rest of us, you'd know that it's NOT the Creative card that's giving me problems.


oww... my head...
"There must be someway out of here, Said the joker to the thief."

#10 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:10:38 PM

Posted 28 June 2009 - 04:00 PM

Some suggestions here might help you
http://en.community.dell.com/forums/p/1927...p;cs=&s=gen
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#11 starcraftmaster

starcraftmaster

  • Members
  • 1,109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:australia
  • Local time:01:38 PM

Posted 28 June 2009 - 10:19 PM

Wow, dude, did you read my last post AT ALL?! If you're not going to pay attention don't try to help; and you could, at the very least, try to type properly.

Once more:
I DID set Audigy as default.
I DID set the correct speaker settings.
I DID look for a jumper and couldn't find one.
I DID look at the manual.

I know how to do this stuff, it's just this one thing that I can't figure out; and the one thing that I need to do to get this working.

And Creative makes the best sound cards out there, it's just the fact that they can't write a decent program to save their asses. I've already dealt with, and fixed, the problems inherit in using a Creative card. But if you'd bother to keep up with the rest of us, you'd know that it's NOT the Creative card that's giving me problems.

oww... my head...


Wow dude
You never said you could not find a jumper.
A dip switch and jumper are a different thing
and I said put audigy AS AUDIGY not as default(dont worry about that one if theres no audigy in the select thing).
You never said you selected the right speaker settings.
http://www.viaarena.com/htmlimages/smart517.gif
This what am talking about if you dont know what i mean.

Also its creative fault because they didit make drivers that would be compatible with people's computers that can't turn off there onboard sound.
if they made their stuff good like they should, it would be a simple fix in device manager by disabling the onboard sound.
But if you'd bother to keep up with the rest of us, you'd know that it's the Creative card that's giving you problems.

Edited by starcraftmaster, 28 June 2009 - 10:34 PM.


#12 All Meshed Up

All Meshed Up
  • Topic Starter

  • Members
  • 46 posts
  • OFFLINE
  •  
  • Local time:09:38 PM

Posted 29 June 2009 - 09:50 PM

----EDIT----

System Restore fixed this.

-------------




Some suggestions here might help you
http://en.community.dell.com/forums/p/1927...p;cs=&s=gen



Well, THAT really screwed things up. I knew manually removing drivers was a stupid idea so I instead moved them to a folder on my desktop. Not only did that not help, but when I replaced the drivers my Audio Compatibly Driver stopped working and I can not for the life of me get it fixed. It can't find it's driver, and won't update. There are no direct downloads online, only a link to a Microsoft site:

http://tc.versiontracker.com/product/redir...bility%20Driver

My laptop doesn't connect to the net (I'm using my Desktop right now) so it doesn't get windows updates. All this site tells me to do is update and install SP3. I'd prefer not to.
This shouldn't be difficult but it sure aint' easy. How do I fix this now?
If I have to install SP3, I will

Edited by All Meshed Up, 30 June 2009 - 01:43 PM.

"There must be someway out of here, Said the joker to the thief."

#13 All Meshed Up

All Meshed Up
  • Topic Starter

  • Members
  • 46 posts
  • OFFLINE
  •  
  • Local time:09:38 PM

Posted 30 June 2009 - 06:04 PM

---- RESOLVED----


Hey, I fixed it!

When I updated the Creative driver it was well after i had uninstall most of the Creative software included with it initially. On a whim I uninstalled everything related to creative, then reinstalled everything on the included CD (with all the useless crap), then updated the driver, then redid all the aforementioned fixing of "the problems inherit in using a Creative card" by uninstalling/disabling everything that is not required by the Audigy. This new driver DOES include the ability to override the on-board audio and after all the reinstalling, it and other features are now active.

from there it was a simply matter of setting the PC to "only use default devices" for audio. However, I still can NOT disable the Sigmatel card or I get no sound at all. Oh well.


So, it seems StarCraftMaster was mostly correct and I'm a douche. :thumbsup:

Edited by All Meshed Up, 30 June 2009 - 06:06 PM.

"There must be someway out of here, Said the joker to the thief."

#14 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:10:38 PM

Posted 01 July 2009 - 02:21 PM

You got it working, that's all that matters
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#15 All Meshed Up

All Meshed Up
  • Topic Starter

  • Members
  • 46 posts
  • OFFLINE
  •  
  • Local time:09:38 PM

Posted 01 July 2009 - 07:43 PM

Ah, gee. Danks mista.

Seriously thank you guys. I've never had an issue gone unresolved after I post it here.
"There must be someway out of here, Said the joker to the thief."




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users