Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB mice suddenly will not work in Windows XP SP2


  • Please log in to reply
2 replies to this topic

#1 VinnyFindley

VinnyFindley

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:13 AM

Posted 23 June 2009 - 09:36 PM

Recently My USB mouse stopped working. I didn't install anything.

I'm running XP SP2 fully updated. Went into control panel and deleted everything under USB rebooted and windows reinstalled all the items that were there. Still no USB mouse.

When any mouse is plugged in it is instantly recognised. Windows found new hardware USB mouse with the name of the mouse and then your new hardware is ready to use but still the mouse won't work.

3 different USB mice won't work on this machine but they all work in the 2 other pc's I have. Tried the mice in the 5 other USB ports but still can't get any USB mouse working. Went out and bought a USB PCI card. Can't get any mouse working in these ports either but anything else plugged into these ports as well work.

Updated to SP3 and still no USB mouse working.

This seems to be a comom problem in Windows. I googled the problem and found a lot of pages ( that's how I found this site ) but no remedy. Very frustrating. I even reinstalled a fresh copy of Windows from an image file that had only the Video and sound card drivers. The only other sofyware is the Comodo Firewall and Vipre AntiVirus.

Came across a few pages with the opposite problem I have. Mouse works but not the keyboard.

System:

Acer Aspire E360
Athlon 64 3500+ with 1 GB ram
Seagate sata 200GB hard drive
ATI HD 4650 PCI Express video card
HD Xplosion sound card.

Onboard audio and video disabled.
All drivers for all hardware are up to date.
USB mouse enabled in bios as well as legacy
All items in control panel are good no Yellow or Red

Main use for this PC is as a HTPC

Vinny

BC AdBot (Login to Remove)

 


#2 Widdybear77

Widdybear77

  • Members
  • 65 posts
  • OFFLINE
  •  
  • Local time:08:13 AM

Posted 24 June 2009 - 08:39 AM

My brother has an Athalon with the same problem.

You'll have to convert your USB mouse cable with a USB/PS2 cable gadget and plug it into the PS 2 port
For him anyway it seemed to be a factor only concerning the mouse. He is a 'diehard' Atholon fan.
Have 6 computers myself 2 are laptop 4 are Pentiums.

Hope this helps....... :thumbsup:

Edited by Widdybear77, 24 June 2009 - 08:41 AM.


#3 Widdybear77

Widdybear77

  • Members
  • 65 posts
  • OFFLINE
  •  
  • Local time:08:13 AM

Posted 24 June 2009 - 08:43 AM

My brother has an Athalon with the same problem.

You'll have to convert your USB mouse cable with a USB/PS2 cable gadget and plug it into the PS 2 port
For him anyway it seemed to be a factor only concerning the mouse. Brother is a 'diehard' Atholon fan.
Have 6 computers myself 2 are laptop 4 are Pentiums.

Hope this helps....... :thumbsup:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users