Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Vaio locks up unless Memory Stick is in slot


  • Please log in to reply
3 replies to this topic

#1 SunBoss

SunBoss

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:14 PM

Posted 22 June 2009 - 03:40 PM

I'm sorry this is so long, but please take the time to read it all because I have already taken a LOT of steps to solve this myself.

I am an IT Professional, and have been since the 80s. The computer I'm having the problem with is mine, it has always had up-to-date AV, and has Automatic Updates on. I check it every so often with SpyBotS&d or MalwareBytes, and it has NEVER had anything besides tracking cookies. It has been on a secured wireless network (out in the middle of nowhere, doubt anyone would hack it), with both a hardware firewall at the DSL entry point and Windows Firewall on. It has never had a Memory Stick in its slot before now. The only removable media I've ever used with it is a big USB disk for backups, which unfortunately has not been done in about 6 months. I've never had Limewire or any other risky stuff installed on this computer. I don't use FaceBook, or any of the social networking, I don't surf any type of risky sites, and I don't download anything onto this computer. Its the safest computer on the planet.

The computer is a Sony Vaio K-series laptop, probably 4-5 years old, running XP Home SP3 and IE8. Here's the sequence of events as best I recall them.

6/10/2009 - everything is fine, I'm looking up something boring like outboard motor parts. Its supposed to storm tomorrow, so I am going to unplug it. Automatic Updates are downloaded and ready to install, so I choose "Install Updates and Shutdown". It does its thing, in a normal amount of time, no indication of problems, and shuts down. I unplug the charger and put it away.

6/19/2009 - I get the computer out, plug it up, push the power button. It gets to the WinXP logo with the progress bar underneath. The bar rotates around a couple times, then sticks. I wait, probably 10 minutes, and nothing ever happens. I notice the orange light is on beside the "Memory Stick" slot.

I boot it up in Safe Mode. (That works.) I check the logs for the Windows Updates, everything appears to have went fine. Check Event Viewer for some clue as to what happened, nothing. Check Device Manager, no splats. Everything looks fine.

Hmmm, maybe a fluke, try a normal reboot again. Exact same result, hangs at same place, with orange light on beside "Memory Stick" slot.

So I boot into Safe Mode, and uninstall all of the Windows Updates that have the 6/10 date on them. I made sure I did them in the correct order, so all dependencies were resolved.

Tried another normal boot. Nope, hangs at same place, with orange light on beside "Memory Stick" slot.

OK, now I'm scared. So I go to my other PC, the desktop and do some Googling of the symptoms. I find one in particular, a malware-infested Sony VAIO locking up with Memory Stick light on. So its probably malware.

Since I already have the latest version of Norton AV, I run a full scan on the Vaio with that. Comes up clean. Then MalwareBytes, latest version, comes up clean. (Then I reboot into Safe mode with Networking.) Then run Housecall online with Trend Micro, comes up clean. Just for S's&G's I even try their New Beta scan, 100% clean. Then Kaspersky's online scanner, also comes up clean. Then BitDefender, again clean. Then as a last resort, I disable NOrton's real-time protection and run Combofix. Combofix did not find anything. (I looked through its logs, but have to admit I'm not that good at fixing something manually.)

I don't know how to interpret Hijack This logs, I always give up before then and reformat. But I have a bunch of old software that I don't know the registration keys for, so I do not want to reformat!

At this point I kinda panicked and tried Restoring Windows to a Restore Point on 6/9/2009. That hosed my IE8. Windows was unable to restore back to the Restore Point that Combofix had just created. :-( So I dinked around with it, reinstalling IE8 and Java. Finally got that working again.

I had read in the post about the malware-laden Vaio, that his booted normally if he put a Memory Stick in the slot. So I was curious about that. I didn't have a Memory Stick, and had never used that feature on the laptop. So I rummaged around and found one, stole it out of hubby's antique Sony Clie'. Powered down the computer, put the Memory Stick in, powered up, and yep it booted normally. :-/ Weird thing is though, when you remove the Memory Stick, it locks up solid. So solid the mouse won't move. Pop it back in, things resume just like normal. ~:-( This is war *&^%#it!!

So I installed Sysinternals' Process Monitor. Started logging, auto-scroll, popped the Memory stick out, made a note of the last entry, then popped it back in, went to look at the entries immediately after re-insertion. Did that quite a few times, but nothing in particular was the very last or the very first thing to run. I disabled or uninstalled the things that popped up the most often, and that made absolutely no difference.

So now I'm waving the white flag, can somebody help? I think I need a ComboFix log interpreter or a Hijack This pro.

TIA (and thanks for reading!)

Edited by SunBoss, 22 June 2009 - 03:42 PM.


BC AdBot (Login to Remove)

 


#2 tortoise77

tortoise77

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:09:14 PM

Posted 23 June 2009 - 09:39 PM

Hello SunBoss

I am happy to report that I have solved the identical problem you describe involving system hang on the Windows XP splash screen and the yellow memory stick light turning on at that point. Similar to your experience I could boot in safe mode but no way to get into a normal boot. As this was a client machine on a limited budget I could not waste a lot of time and contacted the client and got authorization to do a full system restore figuring it would eliminate any software issues (conclusion based on ability to boot in safe mode it seemed reasonable?). Much to my surprise after a full factory restore from the OEM restore DVD the symptom was still there, in fact the restore could not complete because it required a full normal boot to finish the restore. So now I was really perplexed, no way it was software (given that the drive had been fully erased and reformatted), so that only leaves hardware and the memory stick module seemed the likely culprit and on a hunch I tore the bloody thing apart (keyboard, rear hinge cover, and all screws from bottom of the case) which allowed be just enough clearance to get inside and remove the ribbon cable from the memory stick module and presto the problem is resolved and unit now boots normally and I am in the process of bringing the system back up to current standards with all the updates, etc, and have already done multiple reboots with no problems. So I suspect you will find similar results once you go through the difficult task of tearing it apart as our symptoms were identical.

Trust me it has nothing to do with virus or malware activity, it is an actual hardware failure!!

Good Luck

#3 ernamar

ernamar

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:14 AM

Posted 18 August 2009 - 08:08 PM

Hi,
Each of your posts apply exactly to my situation. My Viao is not quite 4 years old, and towards the end of June I started having the same 'boot' issues. Since I require a laptop for work - I figured it was time to replace the old Vaio. Much to my chagrin, it has been a couple of months since I did a full back-up and I use a software application that will not work with Vista. So, I tried booting up my old laptop so I could transfer files. Can't get past the Windows Flash screen, and if I get to safe mode I can't do anything in safe mode. Also, my laptop just keeps trying to boot. I will try using a memory card tonight to see if it boots up.

#4 SunBoss

SunBoss
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:11:14 PM

Posted 18 August 2009 - 08:25 PM

Ernamar: All you have to do is go into Device Manager and Disable the Texas Instrument PCI7420 Integrated FlashMedia Controller.
lol, should have just sold ya my spare MemoryStick...
Cheers!




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users