Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Access denied to certain registry permissions and unable to change this!


  • Please log in to reply
3 replies to this topic

#1 xgeofrey

xgeofrey

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:03:26 PM

Posted 22 June 2009 - 07:44 AM

Hi there,

Somewhat recently, the sound in my internet browser(s) stopped working, and so naturally I began to investigate this cause. Conclusively, I have realised that there are a huge array of problems in my computer.

After a bit of research and 'googling' I found that many installers and programs on my computer are failing to run, as the registry key located at
[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Drivers32]
is unable to be accessed.
After reading a few topics and forums, I realise that this is quite an important registry section to be able to access, and that most likely, this is not only causing a lack of sound in my browsers, but vast quantity of other annoying problems as well.

After discovering this information, I tried a few things to try and fix this issue:
1) I tried right clicking properties (of the key) and changing permissions for certain user groups. It initially appears to have worked, but immediately afterwards they reset. I have also tried this in safe mode.

2) I noticed there was a 'drivers.desc' folder/key next to the drivers32 folder/key containing all the files that my 'drivers32' folder/key should've contained. I tried exporting this file, changing it slightly so it would go to drivers32 when imported. Once again, it initially appears to work, but when I check the contents of the key, there is nothing inside. (as shown below).
Posted Image

If I try to manipulate the folder in anyway, or even export the contents of the key/folder, it errors. I assume these errors are all a result of some sort of 'permissions' failure or otherwise?

I'm unsure as to whether this is relevant, but I did catch a few topics on how this was a security bug at some stage? I did quite a nasty outbreak of viruses some time ago, although I do run windows update quite frequently. I believe that I've fixed most of the viruses. (I hope!) Could this be a residual effect?

Now, I really have no idea where to go from here, or how to fix this, which brings me here. I've attached a HijackThis' log if its of any use at all, and if you need anything else, please don't hesitate to ask, but most of all:
Thanks for taking the time to read this and/or help =]

EDIT: HJT log removed - not allowed in this forum

Edited by garmanma, 22 June 2009 - 10:04 AM.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,753 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:26 AM

Posted 22 June 2009 - 10:10 AM

Repair install should fix whatever is wrong with permissions or system files...if anything.

On my systems...both of the folders you mention have entries.

Louis

#3 joseibarra

joseibarra

  • Members
  • 1,185 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Downstairs
  • Local time:01:26 AM

Posted 22 June 2009 - 12:03 PM

I have never seen an empty system32 folder like that - mine contains drivers for audio and video things.

I have seen that folder attacked by malware that places bogus entries in it that MBAM and others find, but the removal sometimes leaves behind entries in system32 that don't allow things like regedit.exe, cmd.exe, and others to run just by their names alone. At least that is one symptom.

Copying the programs that won't run to other names - like regedit.exe -> jose.exe will run so then you can get into the registry to whack the bogus keys.

The mediocre teacher tells. The good teacher explains. The superior teacher demonstrates.


#4 xgeofrey

xgeofrey
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:03:26 PM

Posted 23 June 2009 - 05:49 AM

Thanks, I managed to solve this problem by changing the permissions from another account in safe mode.

Again, thank you to everyone who read and/or responded.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users