Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Trying to save some files...Midnight Commander


  • Please log in to reply
8 replies to this topic

#1 Aaflac

Aaflac

    Doin' Dis 'n Dat...


  • Malware Response Team
  • 2,307 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:USA
  • Local time:12:47 PM

Posted 22 June 2009 - 01:28 AM

Would appreciate some help. Iím a newbie to Linux!!

How could one save files from a non-bootable Windows, and mount the Windows partition (source), as well as mount a USB pen drive (destination).

Using Dr.Web LiveCD, Terminal accepted a command to detect the Windows disks: fdisk -l
It shows the Windows partition as /dev/hdc1, and the USB pen drive as /dev/sdb1.
The USB pen drive is FAT32.

Then, issued the following commands (not all together!!):
mkdir /mnt/usbsc /mnt/winhd
mount /dev/hdc1 /mnt/winhd
mount /dev/sdc1 /mnt/usbsc

However, this is as far as Iíve gone, and would like to know how to use Midnight Commander (MC) to copy and save the files.

MC has not recognized hdc1 or sdc1. What am I doing wrong?

Also, using MC, how would one see the contents of the Windows partition to save some of the files in it?? What is the right command for this, if one wanted to view what is in Documents and Settings?


Thanks again for your help.

Old duck...


BC AdBot (Login to Remove)

 


#2 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,257 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:10:47 AM

Posted 22 June 2009 - 01:55 AM

try

mount -t ntfs -r /dev/hdc1 /mnt/winhd

to mount the NTFS volume in read-only mode (to prevent further damage)

I've not used MC so I can't offer much help there. I've also never used Dr. Web Live CD, so I'm not sure which filesystems it supports, or if it has the latest NTFS3g driver.

If I were in your shoes (and I HAVE been before), I'd probably be using the Ubuntu Live CD sice I know it can mount USB and NTFS drives easily.

#3 Aaflac

Aaflac

    Doin' Dis 'n Dat...

  • Topic Starter

  • Malware Response Team
  • 2,307 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:USA
  • Local time:12:47 PM

Posted 22 June 2009 - 02:57 PM

Thanks, Amazing Arnold!!

Have seen something like this used:
mount -t ntfs-3g /dev/hdc1 /mnt/winhd

Öthere is no -r, and I understand your rationale for using it
Öthere is ntfs-3g instead of ntfs

From what I found, ntfs-3g is, a driver (so to speak) that supports all operations for writing files. Files of any size can be created, modified, renamed, moved, or deleted on NTFS partitions. It provides safe and fast handling of the Windows XP, and other file systems.

Is there an advantage to using ntfs-3g instead of ntfs in the command:
mount -t ntfs -r /dev/hdc1 /mnt/winhd

Edited by Aaflac, 22 June 2009 - 02:59 PM.

Old duck...


#4 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,257 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:10:47 AM

Posted 22 June 2009 - 03:27 PM

Actually, I think I made a type there. use 3g!

#5 Aaflac

Aaflac

    Doin' Dis 'n Dat...

  • Topic Starter

  • Malware Response Team
  • 2,307 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:USA
  • Local time:12:47 PM

Posted 22 June 2009 - 09:55 PM

It worked:

mount -t ntfs-3g /dev/hdc1 /mnt/winhd

:thumbsup:

Could I have used:

mount -t ntfs-3g -r /dev/hdc1 /mnt/winhd

Or, does the 3g negate the need for the -r?

Thank you very much for your help.

Old duck...


#6 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,257 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:10:47 AM

Posted 22 June 2009 - 10:21 PM

The -r option mounts the filesystem as read only. I suggest you use it in this case, and all data recovery cases.

#7 Aaflac

Aaflac

    Doin' Dis 'n Dat...

  • Topic Starter

  • Malware Response Team
  • 2,307 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:USA
  • Local time:12:47 PM

Posted 22 June 2009 - 11:01 PM

So this would be correct:

mount -t ntfs-3g -r /dev/hdc1 /mnt/winhd

Old duck...


#8 Andrew

Andrew

    Bleepin' Night Watchman


  • Moderator
  • 8,257 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:Right behind you
  • Local time:10:47 AM

Posted 22 June 2009 - 11:40 PM

Yep.

#9 Aaflac

Aaflac

    Doin' Dis 'n Dat...

  • Topic Starter

  • Malware Response Team
  • 2,307 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Location:USA
  • Local time:12:47 PM

Posted 23 June 2009 - 12:10 AM

:thumbsup:

Old duck...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users