Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Seem to have lost RPC


  • Please log in to reply
3 replies to this topic

#1 Rob the doctor

Rob the doctor

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:59 PM

Posted 14 June 2009 - 12:56 PM

Hi Folks,

I've been running XP Home SP3 on an Athlon XP 4000+ for a while now with relatively few problems until a windows update on Friday.

Following this, which didn't appear to have anything controversial in it the whole system has gone a little crazy. Initially it was dropping out and restarting as soon as windows loads while still loading all the usual gubbins that's on my system. It was also complaining about not having a valid boot.ini file.

Safe mode loading hung at Mup.sys, which I'm pretty sure isn't likely to be the culprit and ultimately it took a manual registry roll back from in the recovery console (after running check disc and finding no problems).

Now I find myself in the situation that the system will load in normal mode but RPC will not, the system will restart pretty quickly if I don't set RPC errors to being ignored. sfc /scannow finds a couple of errors but with SP3 installed and an SP1 original CD I'm not getting much joy with repairing those (have tried downloading and extracting developer versions of the service packs into c:\i386). Pretty much anything I know of that will allow me to interrogate the system won't run without the RPC.

Safe mode still hangs at Mup.sys.

The boot.ini file did indeed appear to be entirely absent and replacing it removed the error but still doesn't get things back to normal.

Checked for viruses using an online checker, nil and had run a virus scan the day of the problem which was clean. The blasterworm checkers are clean too.

A repair install of windows hasn't changed anything.

I've considered that it may be hardware but switching out memory modules doesn't change anything and pretty much anything else would require buying new parts for me to test.

Anyone know of anything else that I can try?

Thanks in advance.

Rob.

BC AdBot (Login to Remove)

 


#2 fairjoeblue

fairjoeblue

  • Members
  • 1,594 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:10:59 AM

Posted 14 June 2009 - 02:00 PM

Have you tried doing a System Restore to a date before the problems started ?

Start>Programs>Accessories>System Tools>System Restore.

BTW, Are "gubbins" programs ?
OCZ StealthXstream 700W,Gigabyte GA-EP45-UD3R , E8500, Arctic Freezer Pro 7, 3GB G.Skill PC8500,Gigabyte Radeon HD 4850 OC [1GB ], Seagate 250GB SATA II X2 in RAID 0, Samsung SATA DVD burner.

#3 Rob the doctor

Rob the doctor
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:04:59 PM

Posted 14 June 2009 - 02:40 PM

Aye, system restore doesn't change anything.

Gubbins were things like messenger, zone alarm, avg. Not a lot else on startup.

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,554 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:10:59 AM

Posted 14 June 2009 - 04:17 PM

You can use nLite to slipstream a proper XP CD (with SP3 installed)...and then run sfc /scannow or do a repair install.

nLite 1.4.9.1, http://www.nliteos.com/download.html You will also need to install MS.NET, which is near the bottom of that link.

You cannot do a repair install of a system at SP3 level...with a CD that only goes through SP1. Better to do a clean install and update properly, if you insist on using that CD.

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users