Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

devldr32.exe


  • Please log in to reply
3 replies to this topic

#1 busarider29

busarider29

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:09:59 AM

Posted 14 June 2009 - 12:36 PM

Hello all

Ok....well I made a mistake by not backing up my system before allowing windows to do an automatic update. I did the update and I think that screwed things up with the executable devldr32.exe. Now, when I boot up my machine, an error appears stating "....devldr32.exe failed to initialize properly.....click close to terminate the program...."

I close it out but it keeps trying to start with the same error message reappearing. In the meantime, this is taking up all the processing power so everything I try to do is VERY slow. It will just keep trying to start up and upon looking in the task manager under processes, I can have up to 300+ instances of devldr32 within a couple minutes with it constantly generating more instances of it.

My research indicates that devldr32 is a file associated with the Soundblaster card drivers. I tried deleting the file in Windows\System32 but it won't let me....I assume because the file is being used. I tried pulling the sound card but that didn't work either. I'm not finding the process under the startup or process tabs when I run msconfig to modify startup process and applications.

Right now I'm stuck as to what to try next. Any help is greatly appreciated.

BC AdBot (Login to Remove)

 


#2 fairjoeblue

fairjoeblue

  • Members
  • 1,594 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:09:59 AM

Posted 14 June 2009 - 12:40 PM

Open the Control Panel
Double click the System icon
Click the Hardware tab
Openen the Device Manager
Expand the sound listing
Uninstall the Sound device
Restart the computer
The sound should automatically reinstall & fix the problem.
OCZ StealthXstream 700W,Gigabyte GA-EP45-UD3R , E8500, Arctic Freezer Pro 7, 3GB G.Skill PC8500,Gigabyte Radeon HD 4850 OC [1GB ], Seagate 250GB SATA II X2 in RAID 0, Samsung SATA DVD burner.

#3 busarider29

busarider29
  • Topic Starter

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:09:59 AM

Posted 14 June 2009 - 11:05 PM

Nope....that didn't work. Okay, how do I delete the file from the System32 folder? I delete it and it just re-generates in the System32 folder. Is it even possible? I was able to delete it from the dllcache folder however.

The process kept re-generating until total processes in task manager reached 2100. I don't know if that was coincidental or if it was something that I did to make it stop generating instances of it, or memory won't allow more than 2100 processes??. The only thing I did was rename it in System32 but I don't know how that would stop it because then it just regenerates the file (devldr32) with the original name. Maybe it finally "initialized" properly and that made it stop regenerating instances?? I don't know.

I still need to get rid of it because the file is obviously corrupted or something. So, that's where I'm at right now with it. Any suggestions??

#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,744 posts
  • ONLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:09:59 AM

Posted 15 June 2009 - 09:00 AM

Worth reading, http://www.neuber.com/taskmanager/process/devldr32.exe.html

Louis




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users