Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

RoseOnline dll error in Windows 2000


  • Please log in to reply
1 reply to this topic

#1 hawkster

hawkster

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:21 AM

Posted 01 July 2005 - 10:22 PM

I've tried to solve this problem for like 10 hours now.

Heres the background:
I download a game, i try to start the installation process, i get some error and it doesnt work. I downgrade from XP to windows 2000, that error no longer exists. The installation is now complete. I click on the button to start RoseOnline and I get the following error message:

The dynamic link library d3d9.dll could not be found in the specified path C:\Program Files\Triggersoft\Rose Online;.;C:\WINNT\System32;C:\WINNT\system;C:\WINNT;C:\WIN NT\systerm32;C:\WINNT;C:\WINNT\System32\Wbem.

I then went to this website: http://www.5starsupport.com/info/dll.htm

and copied the d3d9 file. I pasted the d3d9 file into:
C:\Program Files\Triggersoft\Rose Online
C:\WINNT\System32
C:\WINNT\System
C:\WINNT
C:\WINNT\System32\Wbem

I also renamed the same file to d3d9.dll and pasted both files into all of those folders. i get the same error.

There is one point. The icon for the d3d9 file is that of the wavey windows flag, while the icon for all of the other .dll files is the two gears.

Someone please help me solve this problem. I will be forever grateful

BC AdBot (Login to Remove)

 


#2 tg1911

tg1911

    Lord Spam Magnet


  • Members
  • 19,274 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:SW Louisiana
  • Local time:05:21 AM

Posted 03 July 2005 - 03:40 PM

Have you tried registering the .dll?

After copying the selected file to the Windows System directory, it may be necessary for you to register the file. You can use the Regsvr32 tool (Regsvr32.exe) to register and unregister object linking and embedding (OLE) controls such as dynamic-link library (DLL) or ActiveX Controls (OCX) files that are self-registerable. This may be necessary to troubleshoot some issues with Windows, Microsoft Internet Explorer, or other programs. Here's how:

  1. Go to Start>> Run.
  2. Type in: cmd (or command) [Enter]
  3. You will now be in the DOS command prompt screen:
          * To install/register the file type in: regsvr32 file.dll or regsvr32 file.ax (where 'file' is your file name) [Enter]
          * To uninstall the files type in: regsvr32 -u file.dll or regsvr32 -u file.ax (where 'file' is your file name) [Enter]
  4. A message should be displayed confirming that you've successfully registered or unregistered the file.


MOBO: GIGABYTE GA-MA790X-UD4P, CPU: Phenom II X4 955 Deneb BE, HS/F: CoolerMaster V8, RAM: 2 x 1G Kingston HyperX DDR2 800, VGA: ECS GeForce Black GTX 560, PSU: Antec TruePower Modular 750W, Soundcard: Asus Xonar D1, Case: CoolerMaster COSMOS 1000, Storage: Internal - 2 x Seagate 250GB SATA, 2 x WD 1TB SATA; External - Seagate 500GB USB, WD 640GB eSATA, 3 x WD 1TB eSATA

Become a BleepingComputer fan: Facebook




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users