Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Sophos Anti-virus won't enable or install


  • Please log in to reply
5 replies to this topic

#1 tom_h1991

tom_h1991

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portsmouth, UK
  • Local time:06:03 AM

Posted 09 June 2009 - 09:18 AM

Hi Guys!

Recently, my Sophos Anti-Virus wasn't running properly. I had a red shield in my system tray saying my anti-virus was not enabled. I tried to enable it however I was unsuccessful. So I decided to uninstall and reinstall Sophos. However, when I tried install the software in only installs the auto-update program and not the actual anti-virus program.

So I tried several system restores back to when Sophos was running perfectly, but this didn't work.

I then completley removed Sophos again and installed avast! free edition so I had a working anti-virus program running. It found a trojan (named JS-downloader if I remember correctly) when performing a rootkit scan. I deleted this and avast! found nothing else during the rest of the rootkit scan and during quick scan.

I thought that maybe the Trojan that avast! found was preventing me installing Sophos. So I attempted to reinstall Sophos again, however the same thing occured and only the Auto Update was installed.

I have also ran a scan with Malwarebytes' which found nothing.

I'm suspecting there is something lurking on laptop that is preventing me from installing/enabling Sophos, however I am not an expert at these things and would be grateful of your help.

Thanks for any help,

Regards,

Tom.


Edit: I think this may be better suited in the Anti-Virus software section. If a moderator feels it is suitable to move it to that section I would be very grateful.

Edited by tom_h1991, 09 June 2009 - 11:31 AM.


BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,252 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:03 AM

Posted 09 June 2009 - 10:20 AM

FWIW: http://www.sophos.com/support/knowledgebas...icle/11066.html

Louis

#3 tom_h1991

tom_h1991
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portsmouth, UK
  • Local time:06:03 AM

Posted 09 June 2009 - 10:47 AM

Thanks for the reply Louis, but uninstalling Sophos isn't really an issue at the moment. It's the installation i'm having trouble with.

Edited by tom_h1991, 09 June 2009 - 11:32 AM.


#4 hamluis

hamluis

    Moderator


  • Moderator
  • 55,252 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:12:03 AM

Posted 09 June 2009 - 11:27 AM

Well...the reason that the install may not be possible...is that it was not properly uninstalled.

That's one of the reasons why driver problems (and some programs) are typically requiring an uninstall of the old/bad/damaged before the new/good will take.

ATI software/drivers typically work that way, as an example.

Louis

#5 tom_h1991

tom_h1991
  • Topic Starter

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Portsmouth, UK
  • Local time:06:03 AM

Posted 09 June 2009 - 11:31 AM

Oh I see. Well, I removed Sophos in Add/Remove programs. I have just tried the instructions in the link you provided in your previous post, but there are no Sophos folders left in 'Program Files'.

#6 frankp316

frankp316

  • Members
  • 2,677 posts
  • OFFLINE
  •  
  • Local time:12:03 AM

Posted 09 June 2009 - 06:54 PM

Most anti virus products have their own uninstall tools that need to be run as Add/Remove Programs doesn't remove the product completely. You might want to take a look at the Sophos website.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users