Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Windows 2000 SP4 crashes when playing music! COM ports conflict?


  • Please log in to reply
No replies to this topic

#1 KA.

KA.

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:06:31 AM

Posted 05 June 2009 - 04:32 AM

I have a problem with my PC.
At first I thought it was happening when running The Sims (1), but I have found out that the problem is actually happening when playing any sound files.

A brief history.
I am running Windows 2000 sp4.
I basically never use my PC to play games or listen to music, so I never have my speakers turned on.
A month or so ago, I wanted to start playing The Sims again and proceeded to reinstall the game, and several expansion packs.
The game ran fine, and has run fine in the past, but halfway through the process of installing the expansions , I noticed that my CD drive was making a grinding sound when loading/ejecting disks.
I replaced the unit I had with an IOMAGIC 52x Internal IDE drive.
The drive works fine and there were no drivers needed, it works with the cd burning software that came with the old drive.
The point being that I didn't have to install any new software or drivers.

The only odd thing that happened is that, when I installed the new drive, my modem quit working.
I seem to have had this problem before when I added some other piece of equiptment, possibly an extra hard drive.
I finally got the modem working, after physically disconnecting it, starting up the PC, and the reconnecting it and reinstalling the modem drivers.

Anyway, the modem in question shows up as follows:
Modem: Intel® 536EP Modem #9
Attached to: COM10

For some reason, all the other COM ports COM1 through COM9 show as "in use" even though I dont think I have anything using most of them.
No other modems, etc.
I am frankly afraid to mess with those settings too much, because it took forever to finally get the modem working again, and I was having to do it without easy access to the internet.

But here is my problem:
Any time I try to play a sound of any length over a second or two, my system hangs.
I first found this when trying to get The Sims to work (it plays a .wav file in the background).
I would start up the game and the PC would hang up.
I thought I might have a problem with DirectX, so I went through DXDiag to see if I could find anything.
Everything looked okay, no error messages, but just for the sake of completeness I ran the audio tests in DXDiag.
After playing a sound or two, the PC would hang up again.
Tried Windows Media Player, hangs up.
The only sound that seems to work are the "Windows" sound for things like closing files. I usually have those turned off, but I turned them on briefly and it did not hang up.

Anyway, I don't know if I am have having some weird conflict because all those COM ports think they are in use when nothing is really there, or if the drivers for the modem screwed up something with the sound when I reinstalled them, or what.

I was considering getting a new sound card (I currently have CMedia onboard sound that came a part of my SOYO KT333 Dragon motherboard) but if the problem is some kind of conflict then that may not do me any good.

I have tried updating the sound drivers, but that does not seem to help.

Any help would be appreciated, and I will be happy to provide any information needed to help with the diagnosis.

KA.

P.S. I have been doing some more digging. It looks like the Modem and the Sound Card both share the same IRQ, Interrupt Request 11.
Is this normal, or is this the source of the problem?

Edited by KA., 05 June 2009 - 07:09 AM.


BC AdBot (Login to Remove)

 


m



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users