Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Winlogon.exe error message


  • Please log in to reply
3 replies to this topic

#1 Pleather

Pleather

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:07:37 PM

Posted 05 June 2009 - 12:57 AM

Okay, I'm running Windows XP Professional on a Lenovo Thinkpad T60p Laptop, with SP3. If you need any more information, just ask, my computer is still fully functional, and in fact perfectly fine outside of the login process, and the error message itself (which I will get to).

I'll start with only the problem, no history or speculations; This is what happens whenever I boot my computer up (in normal mode, exactly as I have always booted it up, before these problems.)


1. The thinkpad screen appears, like it always has.
2. That little text cursor thing blinks once or twice in the top left of the screen (rest of the screen is black, cursor is white, just like the F8 startup menu, for example).
3. The windows logo appears, with the blue loading bar underneath it.
4. A black screen appears really quickly, which I assume has always been there, I just wanted to make sure I mentioned it.
5. The classic windows wallpaper appears. (You know the one, the field of grass, blue sky with a few clouds.)
--------This is the point at which my computer acts out of the ordinary, and I'm pretty sure that up until this point, everything is has it always has been-----------
6. The little window appears at the center of the screen that has the title "Please Wait..." at the top, and has that animated blue bar, and then the current task windows is performing. It says "Applying computer settings...".
7. About half a second after that, I get an error window with the title "winlogon.exe," and it says,

"The exception unknown software exception (0xc06d007e) occurred in the application at location 0x7c812aeb."

There are three options "OK", and "Cancel", and of course, the 'X' in the top right of the error window, if I click any of them (the X, OK, or Cancel), then the error message will disappear for a brief second, then reappear in the center of the screen, and that entire bar at the bottom of my computer screen (the start bar, my open windows, and the tray) will change into the old gray windows style (instead of my current theme's style, which I will get into later). Then, my computer gives a blue screen with white text at the top that says something like "fatal error, the process winlogon.exe ended unexpectedly, windows has been forced to shutdown", and has some hex code that I never have time to read. I can't read the hex because this screen disappears after about 1 or 2 seconds. Now, this whole process (everything after the window description in item number 7 in my list) of shutting down will occur at anytime I click any of the options on the error message. I have to keep this error message in the corner of my screen the entire time I use my computer, I can move it, but if I click anything on it, then I go through this whole fiasco. In case you're wondering, yes, I have it up right now; I can use my computer, it's fully functional outside of the login process, and this error message.

8. Continuing with the login process, the "Please Wait..." window turns into the "Welcome" window that says,

"Press Ctrl-Alt-Delete to login using a password"

Now, the odd thing about this window is that 2 weeks ago, it would say something like,

"Please swipe your finger.

Or press Ctrl-Alt-Delete to login using a passoword."

My laptop has a fingerprint scanner built in, and I used to use this all the time, but I'll get into that later (among other things...). For now, just know that despite not having the edited text that says "Please swipe your finger," it still has these two illustrations of the fingerprint scanner on the window, one in the top left, and one on the left.

9. I can login with my password just fine, as long as I keep that error message up in the corner

10. What happens next is that the "Welcome" window changes into the "Please Wait..." window again, but this time it says,

"Loading your personal settings..."

and then half a second later,

"Applying your personal settings..."

All the while, my personal background appears. Now I can't tell you if this window used to appear after I logged in with my fingerprint, but I can tell you that if it did, it was surely gone relatively quickly.

11. That window disappears after about a minute, and then very soon after it disappears, I hear the classic windows start up tune, which I'm pretty sure didn't always happen, but I could be wrong.

12. Another minute or so passes, and then the winlogon.exe error window that I had in the corner (or where ever I had chosen to place it) will quickly disappear and then reappear in the center, with the appropriate error sound.

13. My desktop icons will all appear, and my start bar and tray and everything that should appear, appears as if I had logged in normally.

14. Then, I get another window that is titled "winlogon.exe", and says,

"winlogon.exe encountered a problem and needed to close

This error occured on 6/2/2009 at 8:26:39



For more information about this error, click here."

Of course, the appropriate date and time are substituted (I assume around the time I logged in). I can click "Close," and the window will disappear, however, a majority of the time, the window will just reappear in the center of the screen. Every time I login, it will reappear from 0 to 10 times before disappearing for good.

The "lick here" text in the window links to a third error-related window entitled, "winlogon.exe" as well, but it says,


"Error signature

szAppName : winlogon.exe szAppVer: 0.0.0.0 sz ModName : kernel32.dll szModVer : 5.1.2600.5512 offset : 00012aeb


To view technical information about the error report, click here."


This time, "click here" leads to another window named, "Error Report Contents", and says, "


"The following files will be included in this error report:

C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\WER9ee2.dir00\winlogon.exe.mdmp
C:\DOCUME~1\ADMINI~1\LOCALS~1\Temp\WER9ee2.dir00\appcompat.txt

"



It just occurred to me that I haven't checked these files, and though I doubt they will help, I guess it's worth trying.


Now, finally, onto the history and speculations.

The first problems I encountered relating to the login system were all about the ThinkVantage fingerprint software, which allows me to login using my fingerprint. I had always used this method, and it worked perfectly up until recently. My friend accidentally closed the laptop, which is set to go to standby mode upon closing. With standby mode, if I open the laptop again, the login screen appears, and it says something like, "This computer is in use and has been locked by an administrator, please swipe your figner, or press Ctrl-Alt-Delete to enter a password." I didn't tell him the password, so I had to either swipe my finger, or enter the password myself. Since swiping is easier, I went ahead and tried. Unfortunately, it started to act funny. Where it normally would have come up with a little window that says "Processing fingerprint", or something similar, and then another window with some sort of feedback, like "Too short", "Too fast", "Bad Quality," "Fingerprint failed", or even "Fingerprint successful", it only gave me the "Processing" window. Then the window disappeared, like normal, but there was no feedback window. At the time, I just decided to go ahead with my password, because I had no other choice. Soon after, I realized the fingerprinting still wasn't working, so I decided to go into the program and see if I should re-register my fingerprints. I tried to do so, but whenever I attempted to scan any finger, it would come back with "Too short," and then about a half second later, "Lift finger." I assume it thought I my finger stuck on the scanner, which I'm sure I didn't, especially since I tried multiple times. I googled the mishap, and a handful of other users encountered the same odd problem.

http://forums.lenovo.com/lnv/board/message...thread.id=23561

The thread is a bit dated, but the problem described sounded exactly the same, and a few people all had it. One woman claimed to have messed with the hardware,

"i have also taken the palm rest off and reseated the connection for the reader, just in case, however; that failed to do anything either."

and had no luck.

An "Associate Member" gave a few suggestions, and I tried them, first the one about using the second latest update, and then the one about reinstalling the software that came with the laptop, a much earlier version. Neither suggestions worked, and if I recall correctly, I couldn't even get in to my computer after installing the earliest version of the fingerprint software. I had hoped to simply fix my fingerprinting service, but unfortunately, I seemed to have messed up the entire login process. I think I did something with safe mode to fix the problem, and now I'm stuck here. I finally decided to come here before things got any worse, because right now, I can still login, but I almost lost the ability a short while ago.

As for related details and speculations, I recently installed a windows "Theme" to change the look of quite a lot of things, and although it wasn't as intrusive as a transformation pack, I believe it still could have done something, just maybe. It changed the look of all the windows, and the start bar, etc. to look like windows 7. I hate the look of windows XP compared to Vista and 7, but there's no way I'm going to switch just yet, they both seem too unstable.

Anyways, it could be that, or maybe even this recent (Er -- a little less than a month ago, maybe?) update to my thinkvantage software. I vaguely remember something about a "Super Message Center", however weird it sounds. I did notice that instead of the usual "Message Center" service appearing in the tray on start up, the message center is just in the thinkvantage menu. However, I may have disabled the service from starting on boot earlier and not remembered (using CCleaner).

I know this is a bit more specialized than other problems I've seen and posted myself on this forum, or at least I think so, but I'd still rather post this here at the off chance that it can be solved without the help of an IT.

Now, I would like to apologize for this massive wall of text, and that I haven't had the chance to edit/reread it at the time of its posting; my arms are aching, and I'm just short of collapsing on my keyboard, I really need some sleep. I'd also like to thank anyone who took the time to actually read it all over, and I'd like to thank everyone ahead of time for any help I may receive.

Thank you,
Pleather

P.S. I really feel I'm forgetting something here, but I guess that just comes with any large sort of "Project," and I'm definitely not going to take the time to really worry about it at the moment, but it's still troublesome. :thumbsup:.

Oh yea, one more thing; at the moment, I have uninstalled any fingerprint software on my computer as best I could, I had to do this to be ale to log in again, but I should probably update/install the latest version, and see if that works. I don't have the time to test it now, but in the instance that this broader login problem is fixed, I may still be having trouble with the fingerprinting, and in that case, I seriously doubt bleepingcomputer can help; I might just give up on that part.

BC AdBot (Login to Remove)

 


#2 Stang777

Stang777

    Just Hoping To Help


  • Members
  • 1,821 posts
  • OFFLINE
  •  
  • Gender:Not Telling
  • Local time:06:37 PM

Posted 05 June 2009 - 02:07 AM

Have you tried using System Restore and selecting a date before this problem started?
If not, give that a try

#3 Baloo

Baloo

  • Members
  • 243 posts
  • OFFLINE
  •  
  • Location:Ontario, Canada
  • Local time:08:37 PM

Posted 05 June 2009 - 09:19 AM

My users have been having similar issues on all the Lenovo machines in the office. I have uninstalled all the Lenovo software through the Add/Remove programs in the Control Panel and it seems to have corrected the issue.

You could give that a try as well.
When life hands you lemons squeeze the lemon juice right in his eye!

#4 Pleather

Pleather
  • Topic Starter

  • Members
  • 17 posts
  • OFFLINE
  •  
  • Local time:07:37 PM

Posted 05 June 2009 - 12:43 PM

Have you tried using System Restore and selecting a date before this problem started?
If not, give that a try


That was one thing I forgot, I don't have time to elaborate, but I did make multiple attempts to system restore, and it looks like I may not have to, but we'll see when I have the time to work with this, I'll be back later this evening.



My users have been having similar issues on all the Lenovo machines in the office. I have uninstalled all the Lenovo software through the Add/Remove programs in the Control Panel and it seems to have corrected the issue.

You could give that a try as well.


Ahah, I didn't think anyone would have any experience with Lenovos. I will most certainly try this later this evening, and I'll tell everyone if it works.




Edit - Well, on the bright side, everything is back to normal, excluding my fingerprint scanner functionality. Unfortunately, I really can't seem to fix it, and the error is too uncommon for me to find any answers. I've uninstalled, downgraded, upgraded, lots of things, and I still have the same exact problem. Whenever I go to register a fingerprint, and it prompts me to scan my finger, before I even touch the scanner, it says "Too Short", and then half a second later, "Lift Finger." The only thing I can think of that might be causing this issue, is that something is lodged in the scanner, or there is some sort of obstruction or scratch in there. I don't see anything in there at the moment, and I can't really test it at all. For now, I'll just be happy that I don't get that error message anymore. If anyone knows, or even suspects some solution, that would be great.

Oh, and with System Restore, long story short; It didn't fix anything. I might mess with it later, to make sure it still functions correctly, but for now, my main problem is gone, so I'm good.

Thanks for helping guys.

Edited by Pleather, 05 June 2009 - 10:37 PM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users