Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

browsers don't work AIM, nslookup and ping ok


  • Please log in to reply
1 reply to this topic

#1 rangersbball

rangersbball

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:02:55 PM

Posted 28 May 2009 - 06:47 PM

Hello!

I have a Vista Home Premium SP1 with browser problems. IE7 and 8, Firefox, and Opera do not send out TCP/HTTP requests. Using Wireshark, the browser sends the DNS query, receives a reply and then "Can't connect to server". The DNS servers reply with valid and correct IP's from OpenDNS as well as other DNS servers. Using the IP address instead of the name does the same thing - nothing (confirmed by Wireshark).

The system started with IE7 and was updated to IE8 in safe mode after vendio was removed with the same result. All browsers are being run without add-on's.

nslookup and ping work correctly, but telnet www.yahoo.com 80 does not. A sidebar with stock quotes and weather work correctly as well as AIM.

All these symptoms appear when booting and logging in normally. In safe mode, the browsers work normally. In both modes, the networking is normal except for the browsers.

I found and removed Vendio redirecter. MBAM, Ad-aware, spybot s&d, f-secure, bitdefender, and kapersky scanners find nothing (in safe mode). MBAM, Ad-aware, and spybot find nothing in normal mode. I have also run SFC/ScanNow in normal and safe mode and it reports no problems. TcpView shows the browser opening sockets to send/receive, but show no activity other than the udp dns request.

I have also stopped all services that did not seem essential including firewalls, Norton, DNS cache client, etc. with the same result.


Any and all help is GREATLY appreciated.

BC AdBot (Login to Remove)

 


#2 jaybeee

jaybeee

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:02:55 PM

Posted 13 June 2009 - 08:40 PM

I have a friend's laptop showing the same symptoms
Ping is OK , DNS seems ok, ipconfig gives consistent results.
At the moment it is connected wirelessly to my system.
All the other computers on the system work fine, full internet access and all browswers, IE Chrome Firefox and Safari work on all other computers.

On the problem laptop, Ping, email tracert and so on work fine. Running WinMTR shows a steady series of data and resolves the IP names.

So the router is OK
the DNS is OK
it simply looks like the browsers have been corrupted in some way. and seem to be rerouted to localhost or some other unresolvable page.

The caches have been flushed and a myriad of other IP and DNS rebuilding options suggestions on this subject have been tried to reestablish the IP and DNS settings
as the IP and DNS seem fine and are readable by email and WinMTR it seems that only the browsers are the problem.

One other thing, AVG free will not update. It seems malware or a trojan is at fauly but all scans including AVG MAlwarebytes Defender and others all
fail to find the culprit.

This problem was also going around in late 2008

Any help would be greatly appreciated, before the complete reinstall is done in desperation.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users