Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

DVD drive not being recognized by neither BIOs nor OS (Windows Vista)


  • Please log in to reply
1 reply to this topic

#1 LuisAE

LuisAE

  • Members
  • 6 posts
  • OFFLINE
  •  
  • Local time:08:22 AM

Posted 27 May 2009 - 01:04 AM

I have a Dell Optiplex GX280 SD. When I first purchased the PC it came with a CD-ROM drive and Windows XP Professional pre-installed. A few months after purchasing the computer I decided to upgrade my CD-ROM to a DVD-RW/CD-RW (IDE/PATA). I purchased a brand new DVD-RW/CD-RW (IDE/PATA) drive and replaced my CD-ROM with it. Everything worked well, I was able to play CD's, burn movies, etc. A month later I decided to upgrade my Windows XP with Windows Vista Home Premium. I purchased the DVD and installed it with no problems. My DVD-RW drive worked fine, even after installing Windows Vista.

Then, a week or two later I tried playing a CD; I opened my DVD-RW/CD-RW tray, placed the CD inside, then closed it. Usually when I place a CD into my DVD-RW/CD-RW drive and close it a window pops up asking me what I want to do; however, this time it didn't. I went to My Computer and noticed that there was no DVD drive icon under Devices and Removable Storage. I tried restarting my computer in hope that it would reappear but it didn't. I went to Microsoft's website to try and figure out what was the problem. One option was to go to Registry Editor/HKEY_LOCAL_MACHINES/SYSTEM/CurrentControlSet/Class/{4D36E965-E325-11CE-BFC1-08002BE10318} and delete both upper filter and lower filter; however, I was only able to delete upper filter because there was no lower filter. I restarted my computer but unfortunately it didn't work.

So, I restarted my computer and went to Setup then to Boot sequence and beside On Board or USB CD-ROM drive it says (not present), I'm assuming that means it's not recognizing my DVD-RW/CD-RW drive. I shutdown my computer, unplugged the power cable and disconnected the DVD drive, then I reconnected it and made sure everything was securely connected. After plugging the power cable back into the computer I turned on the computer but it still didn't recognize the DVD drive. Then I thought to myself "maybe the drive is dead" but that couldn't be right because once it's connected to the computer I'm able to open and close it. Then, I decided to uninstall the DVD drive and install my CD-ROM to see if it would recognize it but it didn't.

I can't think of any other reasons why it wouldn't recognize my DVD drive. What should I do? Any suggestions?

Attached Files


Edited by LuisAE, 27 May 2009 - 01:06 AM.


BC AdBot (Login to Remove)

 


#2 Sneakycyber

Sneakycyber

    Network Engineer


  • BC Advisor
  • 6,092 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ohio
  • Local time:08:22 AM

Posted 27 May 2009 - 07:57 PM

Seems somethign may have gone wrong with your IDE controller. Try connecting the DVD rom drive on the same cable as your HDD (if you have an available connnector) Each IDE port/channel can support up to two drives. If one channel is bad you can move the drive to the other. Ideally you want the DVD rom drive on a seperate channel the the HDD. If it works you can either switch to a SATA dvd rom drive if your motherboard supports it or you can purchase a PCI IDE controller card.

Chad Mockensturm 

Systems and Network Engineer

Certified CompTia Network +, A +





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users