Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

External HD not visible


  • Please log in to reply
2 replies to this topic

#1 steve1242

steve1242

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:06:05 AM

Posted 19 May 2009 - 09:26 PM

I am having an issue with an Maxtor external hard drive. For some reason it no longer appears under "My Computer" and the program I am using it to store data on doesn't see it either. I am able to go into device manager and check for it and it indicates that it is working properly. Additionally, the Safely Remove Hardware icon appears and when you check properties that way, it also shows up. Other HD and flash drives do appear on this computer. I have attempted to try the Maxtor on another computer and get the same results. Anyone have any ideas?

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 55,252 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:06:05 AM

Posted 19 May 2009 - 09:44 PM

Drive is unreliable...or connections are loose.

I'd check all connections first...then run a disk diagnostic on the hard drive inside the enclosure.

The enclosure could be problematical...or the drive. If possible, I would remove the actual hard drive from the enclosure and connect it directly to the motherboard and see if it is reflected properly in My Computer then.

Louis

#3 mike pyne

mike pyne

  • Banned
  • 6 posts
  • OFFLINE
  •  
  • Local time:04:35 PM

Posted 20 May 2009 - 07:22 AM

Hi Steve,
YOu hard disk is working perfectly, because if there would be an hard disk problem then computer might not able to start , as OD is installed in your hard disk. The only thing is that you cannot see the drive images, then just right click at start butten , a menu will open, select the explorer from the option, then see whether your able to watch drives or hard disk image.
Please revert back for further suggestions.

Regards
Mike




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users