Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

BSOD on ex58-ud3r


  • Please log in to reply
8 replies to this topic

#1 fenixriot

fenixriot

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:09:55 AM

Posted 12 May 2009 - 12:25 PM

i keep getting bsod on my new core i7 system, i have managed to debug the latest memory dump, and i hope you guys can help me out.


Microsoft ® Windows Debugger Version 6.11.0001.404 AMD64
Copyright © Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Windows\MEMORY.DMP]
Kernel Summary Dump File: Only kernel address space is available

WARNING: Whitespace at end of path element
Symbol search path is: SRV*c:\symbols*http://msdl.microsoft.com/download/symbols


Executable search path is:
Windows Server 2008/Windows Vista Kernel Version 6001 (Service Pack 1) MP (8 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 6001.18226.amd64fre.vistasp1_gdr.090302-1506
Machine Name:
Kernel base = 0xfffff800`01e46000 PsLoadedModuleList = 0xfffff800`0200bdb0
Debug session time: Tue May 12 07:28:42.155 2009 (GMT+1)
System Uptime: 0 days 0:05:26.928
Loading Kernel Symbols
...............................................................
................................................................
.....................
Loading User Symbols

Loading unloaded module list
....
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck A, {fffffa60134034d0, 2, 0, fffff80001e17944}

Probably caused by : USBPORT.SYS ( USBPORT!USBPORT_Core_iCompleteDoneTransfer+577 )

Followup: MachineOwner
---------

7: kd> !analyze -v
*******************************************************************************
* *
* Bugcheck Analysis *
* *
*******************************************************************************

IRQL_NOT_LESS_OR_EQUAL (a)
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high. This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arguments:
Arg1: fffffa60134034d0, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, bitfield :
bit 0 : value 0 = read operation, 1 = write operation
bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff80001e17944, address which referenced memory

Debugging Details:
------------------


READ_ADDRESS: fffffa60134034d0

CURRENT_IRQL: 2

FAULTING_IP:
hal!memcpy+204
fffff800`01e17944 488b040a mov rax,qword ptr [rdx+rcx]

DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT

BUGCHECK_STR: 0xA

PROCESS_NAME: System

TRAP_FRAME: fffffa60019c07e0 -- (.trap 0xfffffa60019c07e0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=00000000000004d0 rbx=0000000000000000 rcx=fffffa800a0d44d0
rdx=ffffffe00932f000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80001e17944 rsp=fffffa60019c0978 rbp=0000000000000002
r8=0000000000000008 r9=0000000000000001 r10=fffffa80086739b0
r11=fffffa800a0d44d0 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0 nv up ei ng nz na pe nc
hal!memcpy+0x204:
fffff800`01e17944 488b040a mov rax,qword ptr [rdx+rcx] ds:fb00:34d0=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER: from fffff80001e9a3ee to fffff80001e9a650

STACK_TEXT:
fffffa60`019c0698 fffff800`01e9a3ee : 00000000`0000000a fffffa60`134034d0 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffffa60`019c06a0 fffff800`01e992cb : 00000000`00000000 00000000`00000001 fffffa80`086bd100 fffffa80`0a0d44d0 : nt!KiBugCheckDispatch+0x6e
fffffa60`019c07e0 fffff800`01e17944 : fffff800`01e02cb6 fffffa80`0a0d44d0 00000000`00000002 fffffa80`0abe9100 : nt!KiPageFault+0x20b
fffffa60`019c0978 fffff800`01e02cb6 : fffffa80`0a0d44d0 00000000`00000002 fffffa80`0abe9100 fffffa80`086bd1a0 : hal!memcpy+0x204
fffffa60`019c0980 fffff800`01e0252a : fffffa80`086739b0 fffffa80`0a0d4400 fffffa80`086a2060 00000000`00000008 : hal!HalpDmaSyncMapBuffers+0x1be
fffffa60`019c0a30 fffff800`01e0571f : fffffa80`086739b0 fffffa80`0a0d44d0 fffffa80`086a2060 00000000`00000008 : hal!HalpDmaFlushScatterTransfer+0xae
fffffa60`019c0a80 fffff800`01e04695 : fffffa80`0aa8cc20 fffffa80`0a0d44d0 00000000`00000008 fffffa80`0abe9100 : hal!IoFlushAdapterBuffers+0xaf
fffffa60`019c0ac0 fffffa60`02d2fa47 : fffffa80`086bd1a0 fffffa80`086bd050 fffff800`01e04610 fffffa60`02d2b4fd : hal!HalPutScatterGatherList+0x85
fffffa60`019c0b20 fffffa60`02d30420 : fffffa80`31466d64 fffffa80`0a0d3c60 fffff800`32466d64 fffffa80`00000000 : USBPORT!USBPORT_Core_iCompleteDoneTransfer+0x577
fffffa60`019c0c00 fffffa60`02d2d872 : fffffa80`39585043 fffffa80`086bd1a0 fffffa80`086be088 fffffa80`086bd1a0 : USBPORT!USBPORT_Core_iIrpCsqCompleteDoneTransfer+0x514
fffffa60`019c0c70 fffffa60`02d1a18b : fffffa80`31636f49 fffffa80`086be088 00000000`00000002 fffffa80`086bd1a0 : USBPORT!USBPORT_Core_UsbIocDpc_Worker+0x13a
fffffa60`019c0cc0 fffff800`01ea3cd7 : fffffa80`086be0a0 00000000`34776478 00000000`00000000 fffffa60`0199c580 : USBPORT!USBPORT_Xdpc_Worker+0x26f
fffffa60`019c0d10 fffff800`01ea4e72 : fffffa60`02d19f1c fffffa60`01999180 00000000`00000000 fffffa60`019a2d40 : nt!KiRetireDpcList+0x117
fffffa60`019c0d80 fffff800`020735c0 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x62
fffffa60`019c0db0 00000000`fffffa60 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!zzz_AsmCodeRange_End+0x4
fffffa60`0199cd00 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00680000`00000000 : 0xfffffa60


STACK_COMMAND: kb

FOLLOWUP_IP:
USBPORT!USBPORT_Core_iCompleteDoneTransfer+577
fffffa60`02d2fa47 4d897510 mov qword ptr [r13+10h],r14

SYMBOL_STACK_INDEX: 8

SYMBOL_NAME: USBPORT!USBPORT_Core_iCompleteDoneTransfer+577

FOLLOWUP_NAME: MachineOwner

MODULE_NAME: USBPORT

IMAGE_NAME: USBPORT.SYS

DEBUG_FLR_IMAGE_TIMESTAMP: 479199d8

FAILURE_BUCKET_ID: X64_0xA_USBPORT!USBPORT_Core_iCompleteDoneTransfer+577

BUCKET_ID: X64_0xA_USBPORT!USBPORT_Core_iCompleteDoneTransfer+577

Followup: MachineOwner
---------

BC AdBot (Login to Remove)

 


#2 hamluis

hamluis

    Moderator


  • Moderator
  • 56,565 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:55 AM

Posted 12 May 2009 - 01:03 PM

USBPORT.SYS

Appears to be a Windows driver, http://forum.sysinternals.com/printer_frie...s.asp?TID=14291

My guess would be that this driver is damaged and needs to be replaced. There should be multiple copies on your system (do a Search).

I would replace the one in System32/drivers with a copy from one of the others (probably from an SP download).

Louis

#3 fenixriot

fenixriot
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:09:55 AM

Posted 12 May 2009 - 02:30 PM

well my copy of windows came with the sp already in it, so is there any other way of getting a working copy of usbport.sys?

#4 fairjoeblue

fairjoeblue

  • Members
  • 1,594 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:03:55 AM

Posted 12 May 2009 - 02:48 PM

Open My Computer
Right click on the C drive
On the menu click Properties
When the properties box opens click on the Tools tab
Where it says Error checking click on Check Now
Put checkmarks in both of the little boxes under Check disk opyions
[click on the boxes]
Click Start
You will get a message box, "Could not be performed yadda yadda" just click Yes
Restart the computer
Be patient while the scan runs, let it start to the desktop on it's own.
OCZ StealthXstream 700W,Gigabyte GA-EP45-UD3R , E8500, Arctic Freezer Pro 7, 3GB G.Skill PC8500,Gigabyte Radeon HD 4850 OC [1GB ], Seagate 250GB SATA II X2 in RAID 0, Samsung SATA DVD burner.

#5 fenixriot

fenixriot
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:09:55 AM

Posted 12 May 2009 - 05:28 PM

i have now done this, but does it actually repair files or what?
i need to make sure this file is fixed

#6 fairjoeblue

fairjoeblue

  • Members
  • 1,594 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:03:55 AM

Posted 12 May 2009 - 05:52 PM

Older versions of Windows had "SFC" , System File Checker.
In XP it was replaced [or renamed] CHKDSK , Check Disk .

Go to the conyrol panel
double click Administrative Tools
Double click Event Viewer
Clicl on Application
In the Source column look for >Winlogon , which is a CHKDSK log
Double click it & all that was fixed should be listed.

Also, If your BSOD problem went away it's fixed.
OCZ StealthXstream 700W,Gigabyte GA-EP45-UD3R , E8500, Arctic Freezer Pro 7, 3GB G.Skill PC8500,Gigabyte Radeon HD 4850 OC [1GB ], Seagate 250GB SATA II X2 in RAID 0, Samsung SATA DVD burner.

#7 hamluis

hamluis

    Moderator


  • Moderator
  • 56,565 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Killeen, TX
  • Local time:02:55 AM

Posted 12 May 2009 - 07:26 PM

How To Use Sfc.exe To Repair System Files - http://www.bleepingcomputer.com/forums/t/43051/how-to-use-sfcexe-to-repair-system-files/

Louis

#8 fenixriot

fenixriot
  • Topic Starter

  • Members
  • 4 posts
  • OFFLINE
  •  
  • Local time:09:55 AM

Posted 13 May 2009 - 12:08 PM

i need to know if there is a way of replacing the usbport.sys file, as when i do try and replace mine with a known working one (it is from a vista 64bit version, same as mine) it says i do not have permission, i have turned uac off but still doesnt let me, anyone know how to get round this? or does anyone know if there is a registry fixing program for vista 64bit?

#9 fairjoeblue

fairjoeblue

  • Members
  • 1,594 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:03:55 AM

Posted 13 May 2009 - 12:42 PM

I don't know if it will be of any help but take a look at,

http://support.microsoft.com/kb/941600
OCZ StealthXstream 700W,Gigabyte GA-EP45-UD3R , E8500, Arctic Freezer Pro 7, 3GB G.Skill PC8500,Gigabyte Radeon HD 4850 OC [1GB ], Seagate 250GB SATA II X2 in RAID 0, Samsung SATA DVD burner.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users