Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB devices won't show up in My Computer


  • Please log in to reply
No replies to this topic

#1 IntergalacticShock

IntergalacticShock

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:08 AM

Posted 11 May 2009 - 11:33 AM

Hey everyone, this is my first time here. :thumbsup:
Recently I have found that although my computer will acknowledge my camera, it will not let me access any of the photos on it. I connect the camera to the computer with a USB cord and turn the camera on, but despite the computer showing that it knows the camera has been connected it will not show up as a drive in My Computer. The camera is listed in the device manager and it says that it is working, but still won't let me see the photos. I haven't uninstalled any of the software that came with it and it's all working just fine.
This is the same with my usb memory stick and my ipod, both of them will show up in the device manager as normal but I can't move files on or off either of them. This is especially annoying as I have work that I need to transfer off of my computer using my memory stick because my school won't let us use discs. My ipod will charge but will not show up in itunes.
I don't think this is a problem with my usb ports as I have a wacom graphics tablet that still works perfectly when connected to either port. Lately I've had some trouble with viruses, but I'm not sure if that's related.
Any help would be much appreciated. Thanks.

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users