Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Very strange problem - Unable to play any game online since yesterday


  • Please log in to reply
4 replies to this topic

#1 chaosbringer99

chaosbringer99

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:46 AM

Posted 10 May 2009 - 02:38 AM

Right so Yesterday I booted up my pc and go to play some Eve online but for some reason the game refuses to get past the splash screen, but the process just keeps running. I thought the problem was eve related so I tried searching for some sort of solution relative to the game however none of the solutions I've found seem to work for me. The only way I can get eve to run is to disable my network connection through windows. If I do that and run eve, the game loads up as normal, but if I then enable my connection, I'm unable to log in to the game as it gets stuck at "Authenticating"

So out of boredom I decided to play some DOTA in warcraft 3, but lo and behold I'm unable to connect to battle.net. I'm stuck at "Initiating connection to battle.net..."

I then try to run steam to try some other online games only to get an error window pop up saying:
"Steam.exe - Application Error
The exception unkown software exception (0xc000000d) occured in the application at location 0x301a8a62"

If I try to run steam with my network connection disabled, I dont get an application error but steam requires an internet connection in order to work so that doesn't help.

Next I tried Exteel (a free to play game from ncsoft) which is stuck at "Checking for updates".

s4 league (another free to play online game). The game booted up as normal, but when I enter my details at the login screen I get an error "S4Client.exe has encountered a problem and needs to close. We are sorry for the inconvenience."

Limewire (p2p sharing program) is stuck at "starting connection".

Bitlord (a torrent sharing program) works perfectly fine, and I'm able to browse websites normally as well as upload and download files.

This is the first time I've encountered a problem like this. I can't decided if it's internet or software related. I've done multiple restarts, virus scans, I've reinstalled a few games to see if that changed anything, I've rebooted my router, and tried reconfiguring my router but nothing I do seems to work.

Does anyone have any ideas at all? I'm baffled. I'd do a system restore but I don't have any restore points so the only other solution I can think of is a format but I really don't want to have to do that.

I can't think why having my network connection enabled would cause games to not open or have application errors. I'd understand if I would get connection errors when trying to play online since that would be a simple internet problem but with this my games aren't even functioning properly. All I know is that 2 days ago my PC was working perfectly, but yesterday morning when I turned it on I get this and it's been this way since then. I have made no changes to my pc since 2 days ago So I'm completely at a loss here. Any help would be much appreciated since I'd like to try resolve this before having to resort to a format.

BC AdBot (Login to Remove)

 


#2 Sterling14

Sterling14

  • Members
  • 1,842 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:New York
  • Local time:07:46 PM

Posted 10 May 2009 - 10:21 AM

Are you sure you don't have a firewall blocking the games? Try closing your anti-virus or anti-malware programs and see if that helps.

If all else fails, you can do what I do which is to turn DMZ off in your router. This will completely turn off the router's firewall to your computer. If you let us know what make and model your router is, we can help more. Also, we'll need to know your computer's IP address on the router (not your IP address from your ISP). You can usually find this under network connections, status, and properties.
"I think there is a world market for maybe five computers." - Thomas Watson, Chairman of IBM, 1943

#3 fairjoeblue

fairjoeblue

  • Members
  • 1,594 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:USA
  • Local time:07:46 PM

Posted 10 May 2009 - 10:53 AM

You need to do a malware scan with a utility like Malwarebytes.

You also need to do a full virus scan.

Also, you might want to uninstall Limevirus & get a real P2P program like uTorrent or Bitcomet & use REAL torrent sites.
Just about every computer I've removed viruses from had 1 thing in common , "Limewire" .

People that spread malware & viruses know Limewire is popular with young people so they load it up with nasties.

BTW, It sounds like you have aquired a browser hijacker.

If you do the scans & stiill have the problem download HijackThis & post a log on the HJT section.

Edited by fairjoeblue, 10 May 2009 - 10:54 AM.

OCZ StealthXstream 700W,Gigabyte GA-EP45-UD3R , E8500, Arctic Freezer Pro 7, 3GB G.Skill PC8500,Gigabyte Radeon HD 4850 OC [1GB ], Seagate 250GB SATA II X2 in RAID 0, Samsung SATA DVD burner.

#4 chaosbringer99

chaosbringer99
  • Topic Starter

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:03:46 AM

Posted 10 May 2009 - 10:58 AM

EDIT: Never mind, I fixed it. It was a worm that had gotten into the WINDOWS folder and registry... ffs.

thanks for the replies guys. No I'm certain it's not my firewall or antivirus as I haven't made any changes to my pc and everything was working fine 2 days ago.

I don't really use limewire, i just haven't really gotten around to deleting it. I'm very careful with what I download.

Malwarebytes hasn't come up with anything, neither has NOD32, I haven't checked spybot yet but I have a feeling it wont come up with anything.

I'd just like to add that I recently noticed that trying to run cmd or regedit causes explorer.exe to crash. I've created a thread in the HJT section since creating this thread but it hasn't received any attention yet.

Edited by chaosbringer99, 10 May 2009 - 12:03 PM.


#5 alnn

alnn

  • Members
  • 3 posts
  • OFFLINE
  •  
  • Local time:01:46 AM

Posted 08 June 2009 - 10:48 AM

hi chaosbringer

I have exactly the same problem, but i cant find the culprit

.... can you let me know which software you used to discover the worm ?

EDIT: I have used Mcafee and AVP so far
have also scanned with spybot:S&D

Edited by alnn, 08 June 2009 - 10:55 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users