Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Excellent signal strength, but limited or no connectivity


  • Please log in to reply
12 replies to this topic

#1 finance professional

finance professional

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:01:18 PM

Posted 06 May 2009 - 03:53 PM

Dear members,

I got a new wifi broadband connection and router installed at home. When I try to connect to the my wifi network than for some time it shows "acquiring network address" and after that it shows limited or no connectivity. The signal strenght is excellent.

The ISP technician has created a network icon on my desktop (through create new network wizard). On double clicking it, it asks for username and password, which on entering my internet starts working (while its still limited or no conncectivity in wifi connection!!).

I have tried connecting few other wifi networks, but it shows same, limited or no connectivity error.

I have new Acer Travelmate 4335laptop, core 2 duo, 2 gb ram and Intel ® wireless wifi link 5100 as the driver for wifi.

I would really appreciate if anyone can help me in this.

BC AdBot (Login to Remove)

 


#2 bama_fan

bama_fan

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Alabama.RollTide
  • Local time:03:48 AM

Posted 06 May 2009 - 03:59 PM

any chance you could post the results of a ipconfig /all command......
Posted Image

#3 finance professional

finance professional
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:01:18 PM

Posted 06 May 2009 - 04:04 PM

how can i do that?

I am not that literate in computers :thumbsup:

Edited by finance professional, 06 May 2009 - 04:07 PM.


#4 finance professional

finance professional
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:01:18 PM

Posted 06 May 2009 - 04:36 PM

browsed few posts and i think this is what you are asking ...


Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Admin>ipconfig

Windows IP Configuration


Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Autoconfiguration IP Address. . . : 169.254.192.194
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

PPP adapter BSNL:

Connection-specific DNS Suffix . :
IP Address. . . . . . . . . . . . : 117.198.160.65
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 117.198.160.65

C:\Documents and Settings\Admin>

#5 finance professional

finance professional
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:01:18 PM

Posted 06 May 2009 - 05:30 PM

i tried as per the following thread .. and the error got resolved ... should i trust with ip numbers given by someone else?!?!?

http://www.indiabroadband.net/broadband-ho...nnectivity.html

#6 bama_fan

bama_fan

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Alabama.RollTide
  • Local time:03:48 AM

Posted 06 May 2009 - 07:26 PM

sounds like you set a static ip address......that is the alternative if you aren't able to receive one dynamically (dhcp).....it is possible that dhcp is turned off on your laptop.....you can run the ipconfig command again but this time include the /all (ipconfig /all) which will include additional information.....setting the ip address manually is ok but note that you will have to do this each time you connect to a different wireless network.....chances are you won't know the correct ip scheme (192.x.x.x)......even though you said this has been resolved i would still check to see if we can get your laptop receiving these addresses automatically.....life will be much easier :thumbsup:
Posted Image

#7 finance professional

finance professional
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:01:18 PM

Posted 07 May 2009 - 01:23 PM

yes, you are right. I have to enter those numbers everytime i connect to other networks. I did ipconfig /all and following is the result. Plz do let me know how can i turn on dhcp.

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Admin>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : win-xp
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
Physical Address. . . . . . . . . : 00-1E-EC-C8-6A-D8

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® Wireless WiFi Link 5100
Physical Address. . . . . . . . . : 00-21-5D-41-B8-F4
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.3
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 208.67.222.222
208.67.220.220

PPP adapter BSNL:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 117.198.164.164
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 117.198.164.164
DNS Servers . . . . . . . . . . . : 218.248.255.212
218.248.255.139
NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Documents and Settings\Admin>

#8 bama_fan

bama_fan

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Alabama.RollTide
  • Local time:03:48 AM

Posted 07 May 2009 - 02:24 PM

yes, you are right. I have to enter those numbers everytime i connect to other networks. I did ipconfig /all and following is the result. Plz do let me know how can i turn on dhcp.

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Admin>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : win-xp
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
Physical Address. . . . . . . . . : 00-1E-EC-C8-6A-D8

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® Wireless WiFi Link 5100
Physical Address. . . . . . . . . : 00-21-5D-41-B8-F4
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 192.168.1.3
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Default Gateway . . . . . . . . . : 192.168.1.1
DNS Servers . . . . . . . . . . . : 208.67.222.222
208.67.220.220

PPP adapter BSNL:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 117.198.164.164
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 117.198.164.164
DNS Servers . . . . . . . . . . . : 218.248.255.212
218.248.255.139
NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Documents and Settings\Admin>




you can see in red that it is set to no but this is b/c you have previously set a static ip......you enable dhcp in the same place as you would set a static ip.....only select the radio buttons to obtain both ip and dns settings automatically.....now as long as the wireless network you are trying to connect to is set to issue ip addresses using dhcp, this should work with no effort from you :thumbsup:
Posted Image

#9 finance professional

finance professional
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:01:18 PM

Posted 09 May 2009 - 02:22 PM

Hi,

Selecting radio buttons to automatically select the settings gave same old limited or no connectivity error. (But does this error matter? .. as i can connect to the internet even with this error)

BSNL is the name of my ISP as per following data, dhcp is disabled in router i think. How can i enable that?

Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Admin>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : win-xp
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
Physical Address. . . . . . . . . : 00-1E-EC-C8-6A-D8

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® Wireless WiFi Link 5100
Physical Address. . . . . . . . . : 00-21-5D-41-B8-F4
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.192.194
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

PPP adapter BSNL:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 117.198.161.201
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 117.198.161.201
DNS Servers . . . . . . . . . . . : 218.248.255.212
218.248.255.139
NetBIOS over Tcpip. . . . . . . . : Disabled

C:\Documents and Settings\Admin>

#10 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,588 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:02:48 AM

Posted 09 May 2009 - 09:56 PM

You can connect to the internet with the error because your wired connection takes priority, so Windows ignores the failed wireless situation.

If the wired information is correct, as I gather it is, you do need to enable DHCP and then your ISP will give you IP address, just as you got it on the wired PPP adapter.
You may need to add the gateway address for this connection into the TCP/IP properties of the wireless adapter.
But this should not really be necessary, since your DHCP service is running. It normally finds things by itself.

One thing you could try is disconnect the wired connection for the time being.
Then in cmd window type in ipconfig /release
then type ipconfig
You should see 0.0.0.0 as your IP.
Now type in ipconfig /renew
And wait a bit. I expect you to get IP similar to the one for the wired connection and DNS servers identical. Then when all works fine you can change your DNS servers back to OpenDNS you've entered for the wireless.

There is a twist that I don't know about. Is your ISP permitting more than one IP? I see your wired IP is static from your ISP. Perhaps trying second IP isn't allowed. Ask them.
You mentioned something about having to type in IPs - when and to which adapter?

I hope i haven't confused the issue by some misunderstanding of what's what.

#11 finance professional

finance professional
  • Topic Starter

  • Members
  • 33 posts
  • OFFLINE
  •  
  • Local time:01:18 PM

Posted 12 May 2009 - 02:44 PM

I am sorry, but by wired connection do you mean internet connection through wire?! Well, I have just have a wifi connection, no internet connection through wire.

The ISP technician installed the wifi router in my landline phone. My ISP (BSNL) is a state owned company and the after sales services are pathetic.

I understood enabling/disabling DHCP in my laptop. But how can i enable it in my router? I have marked DHCP settings in red (laptop and router)




Microsoft Windows XP [Version 5.1.2600]
© Copyright 1985-2001 Microsoft Corp.

C:\Documents and Settings\Admin>ipconfig /all

Windows IP Configuration

Host Name . . . . . . . . . . . . : win-xp
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Unknown
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

Media State . . . . . . . . . . . : Media disconnected
Description . . . . . . . . . . . : Broadcom NetXtreme Gigabit Ethernet
Physical Address. . . . . . . . . : 00-1E-EC-C8-6A-D8

Ethernet adapter Wireless Network Connection:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Intel® Wireless WiFi Link 5100
Physical Address. . . . . . . . . : 00-21-5D-41-B8-F4
Dhcp Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
Autoconfiguration IP Address. . . : 169.254.192.194
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

PPP adapter BSNL:

Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : WAN (PPP/SLIP) Interface
Physical Address. . . . . . . . . : 00-53-45-00-00-00
Dhcp Enabled. . . . . . . . . . . : No
IP Address. . . . . . . . . . . . : 117.198.161.201
Subnet Mask . . . . . . . . . . . : 255.255.255.255
Default Gateway . . . . . . . . . : 117.198.161.201
DNS Servers . . . . . . . . . . . : 218.248.255.212
218.248.255.139
NetBIOS over Tcpip. . . . . . . . : Disabled

#12 bookfly

bookfly

  • Members
  • 7 posts
  • OFFLINE
  •  
  • Local time:02:48 AM

Posted 16 May 2009 - 01:28 AM

how can i do that?

#13 tos226

tos226

    BleepIN--BleepOUT


  • Members
  • 1,588 posts
  • OFFLINE
  •  
  • Gender:Female
  • Location:LocalHost
  • Local time:02:48 AM

Posted 17 May 2009 - 10:27 PM

bookfly,
do what??

finance professional,
I might be finally seeing what this is all about.
Broadcom adapter is the wired one and is disconnected.
There is a wireless adapter, the real thing.
There is a virtual adapter - the PPP slip interface for DSL probably.
Is that correct?

In the network properties of the PPP can you not set it to enable DHCP? It's done the same way as for the wired (Broadcom) adapter or the same way as you did for the wireless.

As far as talking to the router - many do not permit access to configuration when in wireless mode. So get a cable, connect computer to the router and try to talk with it over its web interface. Once you setup the router properly, and get a valid IP, take it from there.

Actually, I'm still confused. You did not get IP for the wireless connection (169.x.x.x says bad connection). I think if you resolve this, the PPP interface will take care of itself.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users