Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

USB Speaker - still not working


  • Please log in to reply
2 replies to this topic

#1 PeterChong

PeterChong

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:03 PM

Posted 29 April 2009 - 12:36 AM

I had a pair of USB-powered speaker for my laptop,
It was working well and sounded very good.
When I plug in this time (after 2 month or so )
my laptop does not recognize it, can somebody tell
me why and how to get it working again ?

BC AdBot (Login to Remove)

 


#2 Hertsky

Hertsky

  • Members
  • 28 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Alberta, Canada
  • Local time:10:03 PM

Posted 29 April 2009 - 01:56 AM

Open your "Device Manager"* and check for any Exclamation splats or Red splats ! in the USB section.

Plug in your speakers, and does a text box pop up in the bottom-right of your screen saying something similar to "Windows cannot recognize this device" ?

In device manager Click the [+] to expand the Universal Serial Bus Controllers, again do you see any Warning type splats? Try this first, right click the "Universal Serial Bus Controllers" and click "Scan for Hardware Changes", this might detect and properly setup your speakers. Try restarting your computer after this.




*Opening Device Manager: Click on Start > Right Click My Computer > Properties.
Click the hardware Tab > Click on Device Manager.
Posted Image

#3 PeterChong

PeterChong
  • Topic Starter

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:01:03 PM

Posted 29 April 2009 - 02:37 AM

Thanks Hertsky anyway.
Under The Serial Bus Controller, is stated as " unknown device "
right click & tried 'Install driver' also does not help.
Any other ways ?

Edited by jgweed, 29 April 2009 - 07:59 AM.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users