Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot delete folder


  • Please log in to reply
13 replies to this topic

#1 plank48

plank48

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:11:44 AM

Posted 22 April 2009 - 05:17 AM

Hello all, totally new here but just got a new laptop and don't want it to go the same way as the old one which died so...

Here's my problem, i have a folder on my Western Digital external hard drive which i just can't delete, and i think it may be causing problems. I don't think it's malicious, i've scanned it with Norton 360 and Ad-Aware and they came up with nothing, but my computer doesn't like it.
When i open the folder it contains all sorts of folders and files (far more than it should do) with weird characters such as ▓.╚
It originally contained video files, or at least was supposed to, i downloaded it from DC++ directly onto the drive over a secure network (it's a university network with all sorts of crazy protection) but have never actually seen the video files as it has always looked like this.

Here's what i've tried so far:

Deleting normally (right click\ delete) giving the message 'the filename you specified is not valid or too long' (tried renaming and deleting = same thing)

Deleting using CMD with both cd and rmdir commands, giving the message 'The filename, directory name, or volume label syntax is incorrect' (accompanied by lots of beeping which didn't sound good)

Running checkdisk, which did absolutely nothing.


In addition, whenever i try to remove it using the safely remove hardware tool, it won't let me, even if i've just plugged it in.

It's driving me nuts as you can imagine and any help would be greatly appreciated. Thanks

BC AdBot (Login to Remove)

 


#2 keny111111

keny111111

  • Members
  • 406 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:florida
  • Local time:06:44 AM

Posted 22 April 2009 - 09:21 AM

hello plank48 & welcome to Bc

I have had good luck with STUBBORN files with this little free tool
http://download.cnet.com/Unlocker/3000-2248_4-10493998.html

im sure there are other ways (take ownership) and someone can explain that better than me.so if you are a little patient some one will come along..

good luck :huh:
Have A Great Day

...........Kenny.............

#3 plank48

plank48
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:11:44 AM

Posted 27 April 2009 - 05:34 PM

Cheers, haven't tried it yet cos i'm really busy atm i'll give it a shot and let you know.

#4 plank48

plank48
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:11:44 AM

Posted 31 May 2009 - 06:50 PM

Hi, finally got round to trying this out, and it doesn't appear to have worked. unlocker says it can't delete or move the file. I really want to get rid of the bugger cos somehow it's supposedly 118GB and it's only a 250GB hard drive. Immensely annoying, any suggestions greatly appreciated.

#5 plank48

plank48
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:11:44 AM

Posted 03 June 2009 - 05:36 AM

Ok, not sure if this helps but I created a folder which i gave exactly the same name as the troublesome one and stuck one random .avi file in it of 700MB. I then tried to paste this into the folder which contained the troublesome folder, and got this message:

Error 0x80070570: The file or directory is corrupted and unreadable

saying the .avi file in the created folder was corrupted, even though it plays fine with VLC player and i haven't had any problems with it otherwise. I then replaced the avi file with a PDF file, just to check that there was definitely nothing wrong with the video, and tried pasting it in again, resulting in exactly the same error message.

Please help, this is doing my head in!

#6 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:10:44 AM

Posted 03 June 2009 - 10:58 AM

Hello,

If you use unlocker on a folder that is being used, it will give a list of applications that are using the folder. Are there any when using unlocker?
Regards,

Alan.

#7 plank48

plank48
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:11:44 AM

Posted 04 June 2009 - 08:36 AM

No it just says 'No locking handle found' then asks me what i want to do with it, but whatever i try - apart from renaming - doesn't work, I just get an error message from unlocker saying it can't delete and asking me if i want to try and delete it at the next reboot, which also doesn't appear to happen. It's a bloody stubborn little fella.

#8 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:10:44 AM

Posted 04 June 2009 - 09:01 AM

Have you turned UAC off?
Regards,

Alan.

#9 plank48

plank48
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:11:44 AM

Posted 09 June 2009 - 04:07 AM

I didn't but I have now and it doesn't seem to have made any difference. Also, the file seems to have impossibly got bigger, it now claims it's 214GB, which is actually impossible because as I said before it's only a 250GB drive and the other folders on there add up to about 170GB. Thanks for helping.

#10 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:10:44 AM

Posted 10 June 2009 - 01:51 PM

Have you tried pocket killbox? http://www.pchell.com/downloads/killbox.exe
Regards,

Alan.

#11 MishY

MishY

  • Members
  • 113 posts
  • OFFLINE
  •  
  • Gender:Male
  • Local time:06:44 AM

Posted 10 June 2009 - 03:38 PM

You might need Eraser for this. Being such a large file it may take awhile to get rid of so be patient.
http://www.heidi.ie/node/14

#12 plank48

plank48
  • Topic Starter

  • Members
  • 11 posts
  • OFFLINE
  •  
  • Local time:11:44 AM

Posted 15 June 2009 - 06:54 AM

Thanks everybody for the help but I managed to get it using unlocker in the end, it just suddenly decided to work for some reason, I've searched my laptop and it's definitely gone, just wish I knew what made the difference. Thanks.

#13 nigglesnush85

nigglesnush85

  • Members
  • 4,371 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:UK
  • Local time:10:44 AM

Posted 15 June 2009 - 02:39 PM

Thats good to hear, glad it all worked out.
Regards,

Alan.

#14 markofVis

markofVis

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:11:44 AM

Posted 11 February 2013 - 05:08 AM


 

This problem is no
longer a considered because it has been solved.There is away to fix this
problem and the name of that software is Long Path Tool.I highly recommend it
to you since I have already used it.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users