Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Nokia Software Updater Is "Missing Critical Components"!


  • Please log in to reply
No replies to this topic

#1 lappy

lappy

  • Members
  • 15 posts
  • OFFLINE
  •  
  • Local time:10:17 AM

Posted 21 April 2009 - 06:43 AM

Compy: Dell Latitude D630

OS: Windows XP Professional Service Pack 3

Nokia PC Suite Version 7.1.18.0

Nokia Software Updater 1.5.12en

Mobile: Nokia 5610-d Xpress Music

Mobile firmware version: (as stated when accessing the "software details" window on the phone) V 06.60 07-03-08 RM-242 Nokia

Mobile region: Asia-Middle East

I got my phone new last November. Read somewhere last month that the phone's firmware is actually now at version 9.somethingorother. Well, I thought, time to get updating!

Never having updated the PC Suite software nor the cell's firmware/software, I clicked on the updater through PC Suite, which gave me the following message after appearing to stall on startup for a moment:

"Missing Software Components. Critical software components are missing. Please reinstall."

So I dug around and found out that the PC Suite application itself needed updating. Did that, but the updater still gave me the same message. Did some more digging and downloaded the 22-mb-or-so Nokia Software Updater to go with PC Suite which was found on Nokia's site. Tried again to no avail.

Dug around on the Nokia support forum boards after that. I discovered that many other people were having similar error messages, but the vast majority of them were using Vista and had N95 models, not to mention that the posts were at least a year old. Couldn't find any clear and concise answers to my problems anywhere else, hoping someone here would know what's going on! I've tried reinstalling the program but haven't gone through the registry to get rid of any mentions of Nokia before the reinstallation. I'm too scared to do so as I have other bugs in my system I'm currently trying to fix as a result of testing some Windows tricks to customize my system. However, this Nokia issue is older than the regedit stuff I was screwing around with. Don't know if the cable itself may have anything to do with it, but I've been successfully transferring music and other media back and forth for months. Thanks you guys!

(Possibly related question: Are software/firmware updates ever region locked? Would there be some reason that Nokia would only release the updates for certain regions and not all of them? If so, would that still explain Nokia Software Updater's behavior?)

EDIT: Oh, before I forget, I also tried to update it after enabling/disabling my AV and firewall (Avira Free and its guard feature and Windows Firewall).

Edited by lappy, 21 April 2009 - 06:58 AM.


BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users