Jump to content


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.

Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.


Game won't launch

  • Please log in to reply
1 reply to this topic

#1 mamawcity


  • Members
  • 2 posts
  • Local time:04:11 PM

Posted 19 April 2009 - 07:50 PM

Two months ago I bought and downloaded Galapago from IncrediGames. It worked great the first month then one day when I tried to open the game I got a message that said, "Game launcher has stopped working. I have tried uninstalling IncrediGames and Galapago and reinstalling but it didn't fix the problem. I have also tried installing it from other game sites and still not working. Does anyone have a solution? I even talked with Oberon (however it's spelled) and they never got back with a solution for me. Please help me. I love to play this game!!

Mamawcity is Frustrated!!!

BC AdBot (Login to Remove)


#2 Delta16


  • Members
  • 417 posts
  • Gender:Male
  • Location:Malta
  • Local time:11:11 PM

Posted 21 April 2009 - 02:16 PM

Have you installed anything after you installed and played the game normally ?

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users