Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

sound blaster SB0680


  • Please log in to reply
4 replies to this topic

#1 starcraftmaster

starcraftmaster

  • Members
  • 1,109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:australia
  • Local time:03:54 AM

Posted 14 April 2009 - 12:23 AM

is the sound blaster SB0680 any good?
theres one on ebay so i may buy it just need to know if its any good ?
its pci (I THINK lol) but its the blue pci slot 66mhz one but pci 66mhz will work fine witl normal pci 33mhz yellow slot wont it ?

and will this work fine with windows me?

Edited by starcraftmaster, 14 April 2009 - 12:24 AM.


BC AdBot (Login to Remove)

 


#2 garmanma

garmanma

    Computer Masochist


  • Staff Emeritus
  • 27,809 posts
  • OFFLINE
  •  
  • Location:Cleveland, Ohio
  • Local time:12:54 PM

Posted 14 April 2009 - 10:26 AM

It should
Here's the ME driver for it. At the bottom of the page
http://support.creative.com/downloads/welc...erType=1#type_1
Mark
Posted Image
why won't my laptop work?

Having grandkids is God's way of giving you a 2nd chance because you were too busy working your butt off the 1st time around
Do not send me PMs with problems that should be posted in the forums. Keep it in the forums, so everyone benefits
Become a BleepingComputer fan: Facebook and Twitter

#3 starcraftmaster

starcraftmaster
  • Topic Starter

  • Members
  • 1,109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:australia
  • Local time:03:54 AM

Posted 14 April 2009 - 11:08 AM

thanks

#4 starcraftmaster

starcraftmaster
  • Topic Starter

  • Members
  • 1,109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:australia
  • Local time:03:54 AM

Posted 15 April 2009 - 01:32 AM

wait the link goes back to welcome creative crap lol
can you give a direct link to the file since i cant find it or you can tell me how to find it

#5 starcraftmaster

starcraftmaster
  • Topic Starter

  • Members
  • 1,109 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:australia
  • Local time:03:54 AM

Posted 18 April 2009 - 09:05 AM

ok appears to be working now garmanma
but i cant see any windows me driver or any drivers at the bottem of the page




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users