Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Laptop Keyboard & Mouse stopped working


  • Please log in to reply
6 replies to this topic

#1 fluxx23

fluxx23

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ann Arbor, MI
  • Local time:12:28 PM

Posted 13 April 2009 - 10:43 AM

I'm helping a friend with his laptop because since only a few days ago, the keyboard and mouse stopped working. I had him reboot it a few times but no effect.
I brought over a live linux CD and booted off of that, the touchpad mouse and keyboard worked perfectly.

So I'm guessing there is something with Windows that is stopping it from working. Laptop running Vista Home

Been searching the net and forums but haven't found a solid fix for this.

BC AdBot (Login to Remove)

 


#2 Joshuacat

Joshuacat

    01001010 01000011


  • Members
  • 1,950 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ontario, Canada
  • Local time:12:28 PM

Posted 13 April 2009 - 10:53 AM

Hi. :huh:
What's the make and model of the laptop?
JC

#3 fluxx23

fluxx23
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ann Arbor, MI
  • Local time:12:28 PM

Posted 13 April 2009 - 12:49 PM

Hi. :huh:
What's the make and model of the laptop?


Let's see...

Got here a Gateway MA7

#4 Joshuacat

Joshuacat

    01001010 01000011


  • Members
  • 1,950 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ontario, Canada
  • Local time:12:28 PM

Posted 13 April 2009 - 01:48 PM

I couldn't find the exact support for your notebook on the support site. However, you should try to re-install the Synaptics Touchpad Driver from the Gateway website. Here's the driver, please confirm that the notebook is listed under the Supported Computers and Parts section. If not, go to the main support area site, plug in your serial number/model and look for the driver appropriate for your model.

Gateway Support. - http://support.gateway.com/support/?cmpid=topnav
JC

#5 fluxx23

fluxx23
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ann Arbor, MI
  • Local time:12:28 PM

Posted 13 April 2009 - 02:28 PM

Haven't tried it yet, but the keyboard and mouse won't even work through safe mode, is there another way to get it reinstalled?

Edit: Actually, duh...I'm gonna try and find an external mouse/keyboard I can use to try the reinstall.

Update: Ok, the plot thickens. The external mouse works, but the USB keyboard won't. And I can verify both of these work because I took them from another techs machine for a little bit.

So I'm going to try and wipe out the password file so I can get logged in, then try to reinstall.


Update 2: Wiped the password for the user account. Got logged in and just an interesting note here if anyone else runs across this-->

Device Manager shows the USB Keyboard with error:

"Windows cannot start this hardware device because its configuration information (in the registry) is incomplete or damaged. (Code 19)"

Real quickly I removed both the Keyboard and Mouse from Device manager (uninstall) and ran a 'Scan for new hardware' it detected them but still didn't work.

Still working on the total reinstall. :huh:

Edited by fluxx23, 13 April 2009 - 02:57 PM.


#6 fluxx23

fluxx23
  • Topic Starter

  • Members
  • 38 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ann Arbor, MI
  • Local time:12:28 PM

Posted 13 April 2009 - 03:36 PM

So it looks like what happened, was that my friend installed a keylogger to monitor his kids usage on it.

He did not tell his anti-virus that it was an allowed-program and it promptly removed it.

This would explain it. I reinstalled the keylogging software and it's working now.

Thanks for your help!

#7 Joshuacat

Joshuacat

    01001010 01000011


  • Members
  • 1,950 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Ontario, Canada
  • Local time:12:28 PM

Posted 13 April 2009 - 03:38 PM

Interesting...thanks for letting us know. :huh:
JC




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users