Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Data Execution Prevention Error


  • Please log in to reply
No replies to this topic

#1 Kyle14

Kyle14

  • Members
  • 1 posts
  • OFFLINE
  •  
  • Local time:01:58 AM

Posted 12 April 2009 - 10:45 PM

I have a HP Pavillion laptop and just bought and installed BitDefender 2009 Internet Security yesterday, switching over from Kaspersky 2008 Internet Security. Approximately 20 minutes after I installed the program, I restarted my computer and bitDefender would not open citing a "vsserv. exe Application Error". The error advised me to restart my computer and I did so, only to be faced with the error again.
I then read a post on a support forum and changed my Data Execution Prevention setting to "Turn on DEP for all Programs and Services except those I select" and added the "vsserv. exe" as advised. The startup problem then disappeared.

I proceeded to open my Windows Live Messenger and was able to communicate with all of my contacts except for one. When I click on this contact, the DEP error comes up and crashes my Messenger. I'm able to click on and talk to every single contact except for this one individual. I then checked for any Windows updates, MSN updates, driver updates, absolutely everything. Nothing worked. I turned off my antiphishing protection on BitDefender as advised on another forum, and again nothing. I've uninstalled Messenger then reinstalled it, deleted the contact and readded, absolutely everything I could think of with no luck.

Then, when I started turning on my computer I was confronted with a "hpwamain module has stopped working" error again due to DEP. From there I completely turned off DEP via command prompt run as an administrator, tried running the program, turned it on, changed back to the original setting.. all with no change.

To see if the problem really did come from BitDefender, I ran a System Restore to before I installed Bitdefender IS 2009 and the DEP problem went away. When going to other restore points progressively after BitDefender was installed to see if it could possibly be another program, the problem still occured.

Can somebody please help me.. I have no idea what to do anymore and I'm on the verge of just going out and buying Norton.

Thanks so much,

Kyle

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users