Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

Cannot open Disk management


  • Please log in to reply
11 replies to this topic

#1 sam-my

sam-my

  • Members
  • 122 posts
  • OFFLINE
  •  
  • Local time:04:31 PM

Posted 10 April 2009 - 05:53 PM

When I'm visiting my daughter I use from time to time to check her laptop to ensure everything is in order (programs are updated, registry clean, drives defragmented,...).
She is running Vista home Premium.
Yesterday, I found out two problems:

1. when I right clicked on 'My Computer' and then on 'Manage' I've got a window
C:\Windows\system32\CompMgmt.msc
Windows cannot access the specified device, path or file. You may have the appropriate
permissions to access the item.

It is her personal laptop and she activated the system using her own password.
From whom else to ask permission?

2. I remarked also two gray and hazy icons on the desktop named 'desktop.ini'
the icons are made of a notepad with a spur-wheel on it.
I right clicked on each icon, then clicked on 'Properties' and got this remark on the open window: (open with notepad).
The size of one icon was 174 bytes and the second 282 bytes
When I tried to cancel each icon i got a window:
"If you remove this file Windows or another program might not longer work correctly"

I opened her personal user folder and inside each file of this folder (like: Pictures, Links, Video, Searches, Music Download, Contacts, etc.)
I found the same 'desktop.ini' icon among all the file contents.
Inside the file 'Sample Pictures' (sub-file of 'Pictures') I found two similar icons, the first named 'desktop.ini' and the second 'PCM.db'

What is "the reason" of having these icons there?
Is it possible to remove them safely?

Thanks for your assistance

BC AdBot (Login to Remove)

 


#2 exile360

exile360

  • Members
  • 100 posts
  • OFFLINE
  •  
  • Local time:03:31 PM

Posted 11 April 2009 - 12:59 AM

Greetings Sam-my :huh: .

The desktop.ini files are normal and should be left alone, not deleted. They are needed system files that tell Windows how to display certain folder types (like your desktop, picture folders etc) since each has custom view settings depending on what is usually stored there by the OS.

As far as Computer Management, it's asking for Administrative privelages. By default all user accounts are created as non-admin, standard user accounts for the sake of security, but you should see the screen go dark and a prompt should come up asking for either a click of Continue or Allow or an administrative password (if one was created when Windows was set up).

For more info on UAC (User Account Control) and how it works, please take a look at the following:If you want to not see those desktop.ini files anymore please reverse the instructions here.

I hope I've been helpful :huh: .

Edited by exile360, 11 April 2009 - 01:00 AM.


#3 sam-my

sam-my
  • Topic Starter

  • Members
  • 122 posts
  • OFFLINE
  •  
  • Local time:04:31 PM

Posted 11 April 2009 - 05:38 PM

Many thanks exile360 for your prompt answer.
1. The issue with 'desktop.ini' files has been solved as per the guidance you sent me
2. Regarding the problem of Computer Management, when I'm clicking on 'Manage' I get
the UAC message "Windows need your permission to Continue" and asking for either a click of Continue or Allow.
When clicking on Continue I get the window message:
C:\Windows\system32\CompMgmt.msc
Windows cannot access the specified device, path or file. You may have the appropriate
permissions to access the item.


That is frustrating.
My daughter is the lonely user of her laptop. After the boot process, she is requested to enter her password, to log in.
I understand that from this step, she has logged in 'as Administrator' with all the privileges.

I'm not a Vista user (I'm using XP Pro) therefore I cannot found what is wrong with the above.

Thanks for assistance

#4 exile360

exile360

  • Members
  • 100 posts
  • OFFLINE
  •  
  • Local time:03:31 PM

Posted 11 April 2009 - 11:28 PM

There's a problem with the user permissions on the system. I found a lot of references to this problem (or problems like it) on the net, but no concrete solutions. I'm gonna consult with a couple of gurus on the subject and get back to you. Just hang in there and I'll be back soon :huh: .

By the way, have you had trouble accessing anything else that requires admin privelages? To find out, you can go to the Control Panel and try to access anything that has the little 4 colored shield icon on it (that implies it requires admin privelages and that you will be prompted by UAC). Please let me know so we can determine if anything else with permissions is messed up. Thanks :huh: .

Edited by exile360, 11 April 2009 - 11:36 PM.


#5 exile360

exile360

  • Members
  • 100 posts
  • OFFLINE
  •  
  • Local time:03:31 PM

Posted 12 April 2009 - 12:46 AM

Sorry for the double reply, but at least temporarily I may have a bit of a workaround to let you access it. There are 2 ways:

First Method (easy)
  • Click the Start Orb and type computer management.
  • When it shows up at the top of the Start menu, right-click on it and select Run as administrator
  • Click Continue at the UAC prompt
  • If this method is unsuccessful, continue to the second method.
Second Method (more complex)
  • Click on the Start Orb and type cmd
  • When it shows up at the top of the Start menu, right-click on it and select Run as administrator
  • Click Continue at the UAC prompt
  • In the command prompt window type or copy/paste the following exactly as written:
    MMC compmgmt.msc
The only other option I know of (so far, until I consult with my friend) would be to run an administrative command prompt (as instructed above) and type or copy/paste the following exactly as written:
secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose
Once the command completes, reboot the PC and see if you now have access. This may not work however, because as I recall, the home versions of Vista don't support the secedit command :huh: .

edit: I think I finally found the right fix from Microsoft themselves. Download and run this and it should fix you right up. For more info on user permissions you can also refer to this MS Knowlegebase Article (that's where I located the fix).

Please let me know if it works :huh: .

Edited by exile360, 12 April 2009 - 07:43 AM.


#6 sam-my

sam-my
  • Topic Starter

  • Members
  • 122 posts
  • OFFLINE
  •  
  • Local time:04:31 PM

Posted 12 April 2009 - 04:02 PM

Hello exile 360

First of all thank you for your time.

1. I had a glance at the Control Panel and found some files (3 ea) that require administrator privilege (that has the little 4 colored shield icon on it)
I clicked on Continue and the process was ready to start (i.e. not blocked).
these files were:
'Turn Windows feature on or off'
'Create a restore Point'
'Repair Windows using System Restore'

2. I used the "First Method" and could open the computer manager
I used also the first part of the "second Method" which open also successfully the Computer management files.

3. But. When I tried opening it by right clicking on My Computer, I was blocked again.
i.e. opening the Computer management can be achieved only through the Start menu

Thanks

#7 exile360

exile360

  • Members
  • 100 posts
  • OFFLINE
  •  
  • Local time:03:31 PM

Posted 12 April 2009 - 11:05 PM

You're very welcome :huh: . At least we found out alternative ways to open it. Did you happen to try the fix I added at the end of my last post yet? It might fix the issue once and for all (hopefully).

#8 sam-my

sam-my
  • Topic Starter

  • Members
  • 122 posts
  • OFFLINE
  •  
  • Local time:04:31 PM

Posted 16 April 2009 - 02:27 PM

Hello exile360

I tried the 'fix' today.
Same situation.

Since its not my laptop, I think to take your advise:
"At least we found out alternative ways to open it."

unless I will find a thread where someone else has had the same problem.. .and solve it.

Thanks for your time

#9 exile360

exile360

  • Members
  • 100 posts
  • OFFLINE
  •  
  • Local time:03:31 PM

Posted 16 April 2009 - 10:41 PM

You're very welcome :huh: . Good luck finding another thread, I couldn't unfortunately, but it's probably something related to a corrupt key in the registry that points to that context menu entry, but it would most likely not be worth playing with since messing with the registry without proper understanding to fix something so minor can often do more harm than good.

#10 Jove

Jove

  • Members
  • 2,739 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Very South Jersey
  • Local time:05:31 PM

Posted 30 January 2010 - 01:03 AM

Hello !

Can anyone tell me do any of these fixes apply to Windows XP ?


Sorry for the double reply, but at least temporarily I may have a bit of a workaround to let you access it. There are 2 ways:

First Method (easy)

  • Click the Start Orb and type computer management.
  • When it shows up at the top of the Start menu, right-click on it and select Run as administrator
  • Click Continue at the UAC prompt
  • If this method is unsuccessful, continue to the second method.
Second Method (more complex)
  • Click on the Start Orb and type cmd
  • When it shows up at the top of the Start menu, right-click on it and select Run as administrator
  • Click Continue at the UAC prompt
  • In the command prompt window type or copy/paste the following exactly as written:
    MMC compmgmt.msc
The only other option I know of (so far, until I consult with my friend) would be to run an administrative command prompt (as instructed above) and type or copy/paste the following exactly as written:
secedit /configure /cfg %windir%\inf\defltbase.inf /db defltbase.sdb /verbose
Once the command completes, reboot the PC and see if you now have access. This may not work however, because as I recall, the home versions of Vista don't support the secedit command :huh: .

edit: I think I finally found the right fix from Microsoft themselves. Download and run this and it should fix you right up. For more info on user permissions you can also refer to this MS Knowlegebase Article (that's where I located the fix).

Please let me know if it works :huh: .


When you don't have to worry about your computer anymore, you can start
living again !

vrwqzc.gif
Success is a result, not a goal. . . . Flaubert


#11 rowal5555

rowal5555

    Just enough info to be armed & dangerous...


  • Members
  • 2,644 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:St Kilda, Dunedin. South Island. NZ
  • Local time:10:31 AM

Posted 30 January 2010 - 01:41 AM

Very good reply, thank you exile360.

@ Jove. XP and Vista are both mentioned in the link

http://support.microsoft.com/kb/313222

rowal5555 (Rob )                                                             

Avid supporter of Bleeping Computer's
Team 38444

You can help find a cure


 


#12 Jove

Jove

  • Members
  • 2,739 posts
  • OFFLINE
  •  
  • Gender:Male
  • Location:Very South Jersey
  • Local time:05:31 PM

Posted 30 January 2010 - 08:47 AM

Hi there rowal 5555,

Thank you !

When you don't have to worry about your computer anymore, you can start
living again !

vrwqzc.gif
Success is a result, not a goal. . . . Flaubert





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users