Jump to content


 


Register a free account to unlock additional features at BleepingComputer.com
Welcome to BleepingComputer, a free community where people like yourself come together to discuss and learn how to use their computers. Using the site is easy and fun. As a guest, you can browse and view the various discussions in the forums, but can not create a new topic or reply to an existing one unless you are logged in. Other benefits of registering an account are subscribing to topics and forums, creating a blog, and having no ads shown anywhere on the site.


Click here to Register a free account now! or read our Welcome Guide to learn how to use this site.

Photo

game cds causing controller error


  • Please log in to reply
No replies to this topic

#1 anthropomorphic

anthropomorphic

  • Members
  • 2 posts
  • OFFLINE
  •  
  • Local time:05:46 AM

Posted 21 March 2009 - 09:03 PM

I just purchased a new copy of Empires II (yes you can still do that) which contains the original and expansion cds. I have 2 computers both running Vista home basic. One dual boots with Ubuntu. Both have dvd writers. The game installs and runs fine on both but on the dual boot the game is very slow to load from either cd. They make a racket when they autoplay then load in the setup ok but after clicking play the drive attempts to load for about 3 minutes, then makes a racket and the cd loads in. Both disks do the same thing for about the same length of time. I haven't had any trouble with the drive before although it seems noisy sometimes. They load normally on the other computer. First thing I tried was cleaning the drive but that didn't help. I attached an external usb cd drive to the dual boot and the games load fine. I installed them under wine in Ubuntu and both drives load the disks in quietly and the game runs ok. I also tried running a couple of other games from cd in the offending drive and there were no problems. It would appear that the problem is specific to these particular cds and the dvd drive in my Windows configuration. I want to give the external drive to someone who needs it so I went looking for solutions. A check of the event viewer showed that a controller error on \Device\CdRom3 was causing the hold up and only for those 2 disks. I read through a bunch of posts on this forum and followed some directions but that just lead to more concerns and problems. I went to the registry editor to delete the upper and lower filters and discovered the key or guid (not sure of correct term) was repeated multiple times which rather alarmed me. I didn't look through all of them but I could only see the upper filter listed in the first one so I didn't bother with that. I then just removed the drive from device manager and reinstalled it. That didn't help anything. Also I don't seem to have an advanced settings tab for any of my drives in the device manager so couldn't tell you if dma is enabled or not. Probably not with all these errors. I don't have that Intel accelerator software installed that usually causes that so I don't know why that is. So something ain't right. I don't think either trying to get replacement cds or replacing the drive will solve my problems and I'm now worried about what's going on in the registry and why the advanced settings aren't showing up. I guess I could try setting up a lan game from Ubuntu to Vista but that could be headachey. Any ideas anybody?

BC AdBot (Login to Remove)

 





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users